Here is my fix..

in the bios sellect MIT menu.
CPU Features,
Disable CPU Enhanced halt C1e
Disable C3/C6/C7 State Support
Disable Cpu EIST function.

save then exit.

If it works for you please post here with the board type and revision.

Mine did it on F3-F4j and on a EX58-Extreme.