UD5, 12GB Memory, F4 Release Bios, i7 920

I have seen some vauge references to a multiplier issue, but nothing solid if anyone has any clues let me know.

Intially I could OC using just BCLK up to around 180 with Multiplier set to 20x, all else on AUTO.

After a few BIOS updates I started to see off behavior.

In the 20x range I could post up to 133 thru 150, and 184 thru 200, but anything inbetween ( 151 thru 183) will not post at any volts/settings.

Change Multiplier to 19x and the range that did not work 151 thru 183 suddenly does, but 20x range is problematic

I reverted the bios and the behavior remains, this seems like a bios logic error to me, but I cannot get the board back to the state where it would except 20x multiplers

Strangely enough using EasyTune 6 and selecting 3.2 (20x) worked!?!

Looking at all the volt's etc. in ET6 advanced all looks like what I had set (even tried manually setting EVERYTHING to ET6 settings, wiht nothing on auto to match, still no joy!) so they must be doing some other magic that isnt easily seen in ET6 (not sure if ET6 does things on boot or just bios)

When I use 19x and post/vista is ok, but turning on intel turbo boost (no other changes) I get an immediate BSOD in windows (obvioulsy upping the multipler to 20 (from 19) causes the same issue, so 20x is the culprit.

Again since ET6 can boot into 160, 20x this would seem to be some kind of Bios/Logic issue

Anyone have any clue what's going on?