Is there some kind of malware that can infect BIOS?
(If so, how to kill it?)
Or am I missing something obvious?

It's been nearly a week since my woes began...

All cables and connectors, checked swapped, and retried.
Clear CMOS pins shorted several times (after power off!).

Example, my newly built system will read the Hiren Boot
CD menu, but highlight will not move to Boot CD option.

Gigabyte GA-MA78GPM-DS2H
Phenom 9850
Corsair RAM (2 GB x 4)

Problems with old system

Briefly, I was forced to upgrade my MSI AMD 939 system
earlier than I wanted to because a reinstallation of XP Pro
ended with the motherboard not being able to recognize
any hard drives - persistent boot error message after
successful POST bootfix, etc. were ineffective.

Trying four different hard drives, Googling, and doing
everything else I and patient friends could think of,
that problem vexed me for about 25 or 30 hours over
four days.

I noticed that one of the heat sinks over a chip on the MSI
motherboard had what looked like a scorch mark on
one corner and suspected that it was a hardware failure
on a three-or-four-year-old board.

But, in the light of my experience, with the new installation
it might have been something else.

I didn't want to upgrade until USB3-enabled boards hit
the market, but I need a reliable working system for my
work and my hobby (photography).


MA78GPM-DS2H fine at first

I went for an inexpensive Gigabyte board and
a Phenom 9850. A friend I phoned for help told me
she had migrated to Mac and would let me have her
Win XP 64 disc. She said that DDR2 RAM is fairly inexpensive
now and XP 64 would let me go beyond the 3 GB limit of
32-bit OSes. That sounded promising.

I was surprised by the trade-in price of my 4400 X2
and 2 x 1 GB of Corsair PC3200, which went towards
extra RAM.

The installation went fine (on a clean 2-year-old WD 320 GB drive).
I logged on to Microsoft and downloaded all recommended updates.

I flashed the BIOS to F3 (that was so simple!)

Then, I did two things that might be relevant to the problem:
-> Foolishly confident, all at once, I installed another three (SATA)
------____hard drives in the system (in addition to the single SATA hard
------____drive and IDE optical drive); and
------->Trying to get things to work my way, I changed the drive letter
------____assignments.

I hard rebooted after changing the drive letter assignments.

Then, while surfing with Explorer 8 beta (AVG, windows firewall
and MVS Hosts file in place) the BSOD flashed briefly
and the system rebooted.

It tried to boot from the previous hard drive that I
had installed for data extraction. The boot froze at the user
log-in screen.

I unplugged that hard drive and tried again.
The first message I got was ntoskrnl was corrupt or missing.

So I put the XP 64 installation CD in the CD in the hope of
accessing the repair console.

It would not boot from CD.

POST completed. After the DMI pool message
I was told that no hard drives are accessible.
Ctrl-Alt-Del would not work.

After rebooting with the powerswitch,
I tried the Hiren boot CD.
There was a moment of brief elation the menu
appeared

Boot from hard drive

Boot CD
[Other item]


But the down key would not move the highlight from
the top item (possibly, the system was frozen)

The next time, I couldn't get the system to read the disc.
It seemed to me that the optical drive was being recognized
as a hard drive.

That was late last night, and I went to bed hoping the
solution would visit me in the night.

I woke optimistically this morning with the idea that
shorting the Clear CMOS pins would work.

It didn't.

Then I tried booting from a borrowed USB DVD drive
plugged into the USB port.

The result, with Hiren boot disc, was the boot from CD option
was unusable.

The system will not boot even when the only drive is either an
IDE optical drive or a USB optical drive.

I don't have a floppy drive and I just don't know
what to do.

I could use my XP Pro disc to prepare a drive in another
system, but I am not confident that will work. And anyway,
I want to understand what is happening.

I have tried starting from scratch with clean and umcompromised
drives but nothing will get the system going.

The only other thing I can think of is the power supply,
a 500 W Scythe. It's a few years old.

Any hints would be greatly appreciated.

I don't want to migrate to Mac!