Hi

I've just installed the following:

Gigabyte GA-P35-DS3R Motherboard
Intel Core 2 Quad 8400 CPU
4GB DDR2 RAM (OCZ 2x 2GB twin set PC2 6400)
ASUS EN7300GT 512mb Graphics card
SATA HDD and SATA DVD

It worked fine in my previous case up until i changed them over to a new case. then the monitor did not receive signal. so i tried everything that ended up to resetting CMOS battery. monitor works after that but it stops dead at the first logo screen (Gigabyte S-series logo). I'm not able to use the keyboard,and I've tried several keyboards to make sure it wasn't the problem. I've also tried to disconnect the HDD and DVD to ensure that wasn't causing problems. I have gone through installation twice.. disconnecting everything but the CPU. All fans are running as they should, and the phase LEDs are all lit. The system emitts one "beep" at startup.
i also tried to install 1 device at a time and switch it on every time a device installed to find the broken device. start with CPU (continues beeping 'beep beep beep beep'). then graphic card (still beeping and no picture) then RAM ( beep once at start same time keyboard led flash once, screen shows logo screen and thats it. i cant go anywhere from there, press any key and it just stay).

someone out there please help me.

Cheers
adam