Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Gigabyte Crossfire Agony!




  1. #1

    Default Gigabyte Crossfire Agony!

    Hi,


    Just wondering if anyone has a Gigabyte GA-x48-ds5 (or similar) mobo with 2x Gigabyte 4870 1gb in crossfire?


    Im trying to get it to crossfire but I will be stuffed If i can do it. I essentially get dont get a crossfire option. Booting into windows, it detects both cards in device manager but in the Graphics Hardware section, i get 1 primary adapter and 1 disabled adapter as shown in these images:


    ImageShack - Image Hosting :: crossfire3.jpg
    ImageShack - Image Hosting :: crossfire4.jpg
    ImageShack - Image Hosting :: crossfire5.jpg
    ImageShack - Image Hosting :: crossfire6.jpg







    The issue has been documented here apparently :
    http://forums.amd.com/game/m<wbr>essageview.cfm?catid=262&thr<wbr>eadid=10495 1&STARTPAGE=1&FTVAR_FORUMVIEWTMP=Linear
    I have tried these suggestions and still get nothing.
    Im stumped and about to admit defeat, but, hoping for a glimmer of hope, am reaching out to this forum.



    I have;
    Tried every Catalyst drivers under the sun: check
    Driver cleaned after every CCC install: check
    Installed single card, then CCC, then second card, then CCC, then add xfire bridge: check
    Tried using Acronis image of computer when 1st built: check
    Flashed mobo bios 8C: check
    Flashed 4870 bios 23: check
    Tried Windows 7: check
    Tried Vista 64: check
    Hit up AMD Crossfire forums: check
    Installed and reinstalled both cards into PCIE slots: check
    Emailed Gigabyte support: check [They said to ensure crossfire bridge is properly secured (Like I havn't tried it a million times already) and to download latest Mobo bios. I had the most current, non-beta bios, so I got the beta)


    I have spent about 4 weeks trying to get this to work but im out of ideas. Anyone with this configuration get it to work, and if so how?!? Also anyone with ideas would be HUGELY appreciated.


    Current specs:
    CPU: e8500 oc to 3.8ghz
    Motherboard: Gigabyte GA-x48-ds5 Rev 1.3
    Memory: 4gb (2x2gb) Kingston Hyperx 1066
    Hard Drive: 1x Western Digital 1TB 7200RPM 32MB Cache, 1 Western Digital 1TB 7200RPM 16MB Cache
    Video Card: 2x Gigabyte 4870 1gb
    Monitor: BenQ G2400WD
    Case: p182
    PSU: Corsair hx-620
    Cooling: Noctua C12P
    Optical Drive: Pioneer DVD R/W, LG Blu Ray
    Wireless Network Card: D-Link Wireless DWA-520
    Operating System: Windows Vista Ultimate 64-bit SP1 and Windows 7 Build 7100

  2. #2
    Join Date
    Jun 2009
    Location
    Australia
    Posts
    7

    Angry Re: Gigabyte Crossfire Agony!

    I have the same issue with the same result after similar levels of testing.


    Current specs:
    CPU: Phenom II X4 Quad Core 955 Black Edition CPU 3.2Ghz
    Motherboard: Gigabyte GA-MA790FXT-UD5P MB, AM3,790FX+SB750 Rev 1.00 with latest BIOS from Gigabyte.
    Memory: 2 x Corsair TW3X4G1600C9DHX 4GB (2x XMS3 2GB) PC-12800
    Hard Drive: 1x Samsung 300G SATA II
    Video Card: 2x Gigabyte ATI HD4870 PCI-E 2.0 1GB 256-bit GDDR5 (came with latest BIOS version available on Gigabyte site. )
    Monitor: Samsung 24inch DVI connection.
    Case: Antec 300
    PSU: Corsair TX-850
    CPU Cooling: Stock AMD Cooler.
    Operating System: Windows 7 x64 Build 7100

  3. #3

    Unhappy Re: Gigabyte Crossfire Agony!

    The biggest trouble for me is trying to identify excatly what is at fault with my config.

    Based on your situation Sirlac, I ma beginning to think it must be something with the cards themselves...

    Im unsure if I even have rights of return as each card works individually but not in crossfire...

  4. #4
    Join Date
    Jun 2009
    Location
    Australia
    Posts
    7

    Default Re: Gigabyte Crossfire Agony!

    B1essed,

    According to my research it is most likely fixed by a BIOS change required on the cards. This thread seems to indicate that 4850's and 4870's don't work in Crossfire and the only resolution is a BIOS patch that works for other brands of cards.

    I have emailed Gigabyte Tech support 2 days ago and am still awaiting a reply.

    I even upgraded my power supply from 650W to 850W just in case it was power related but alas have the same problem.

  5. #5

    Unhappy Re: Gigabyte Crossfire Agony!

    Sirlac,

    I have been through the AMD boards with a fine tooth comb and I even linked that page in my original thread. But thats all good, I have been through all that they suggested and have flashed the cards to the latest Bios (23) and still I get nothing.

    On a side note, i have been down the Gigabyte support route and suffice to say, i was treated as an idiot. For instance, outlining all the things I have done (as outlined in my original thread), their suggestion was to check the crossfire ribbons (like wtf?!?) and flash the mobo bios. I flashed the mobo (it was at F7 and I went to F8C which is a beta) and still nothing.

    I replied to them outlining all the other testing I had done which included trying the new Catalyst 9.5 drivers. Their short and sharp reponse was to try the new 9.5 drivers...

    I dont even think they are reading what I am writing to them and are simply trying to palm of easy answers.

    Thanks for your interest in this anyway. I suppose we are both in the same boat together so if a miracle occurs, I will let you know but at this stage, I am considering a return of both cards and changing manufacturer.

  6. #6
    Join Date
    Jun 2009
    Location
    Australia
    Posts
    7

    Thumbs down Re: Gigabyte Crossfire Agony!

    Oops. My applogies for posting the same thread. Problem when trying to multitask and skimming through things.

    That is rather depressing about Gigabyte Tech Support. Maybe we should have named this thread "Gigabyte 4870's do not work in Crossfire Mode!"

    That might prompt someone who knows something to respond or get Gigabyte's attention.

  7. #7
    Join Date
    Jun 2009
    Location
    Australia
    Posts
    7

    Default Re: Gigabyte Crossfire Agony!

    B1essed_P14gue,

    After posting here I was checking the BIOS page for the GPU's and there looks like there is a new BIOS posted yesterday for the GV-R487D5-1GD!. I won't have a chance to test this till tomorrow. Fingers crossed!



  8. #8
    Join Date
    Jun 2009
    Posts
    2

    Default Re: Gigabyte Crossfire Agony!

    Well I felt the need to create an account here just to let you guys know that....

    IT WORKS!

    Flash the bios with Gigabytes @bios program (done all in windows, don't need to boot it or anything), restart and a happy new window pops up to say hello.... and a lot of frustration is thankfully released!


    Also I thought it was interesting to note that some guy over at techpowerup (What driver do you recommend for Crossfire 4870? - Page 2 - techPowerUp! Forums) had called gigabyte tech support about a week ago and was given a prerelease version of this bios which worked too. I guess you occasionally run into a support guy over there who's actually willing to help lol.

  9. #9

    Exclamation Re: Gigabyte Crossfire Agony!

    Hi Alfangus,

    So you are saying that you had this exact same problem and with the drivers released recently, you got crossfire to work?

    Can you tell me the specs of your system please.

    I can only pray to the powers that be that this new bios will work...

  10. #10

    Lightbulb Re: Gigabyte Crossfire Agony!

    Gimme a couple of hours Sirlac and I will be all over this like a fat kid on a cupcake...

    Update soon

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •