Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: System boots, but installation stalls




  1. #1
    Join Date
    Jun 2009
    Posts
    2

    Default System boots, but installation stalls

    Hi all

    I am trying to install some linux on a box I built yesterday. I've tried Kubuntu, Lenny, a Lenny custom backport I was recommended, Mandriva, and Fedora. No dice.

    First, parts:
    Gigabyte GA-MA790X-UD4P
    AMD Phenom II X3
    Western Digital Caviar Black SATA

    The gigabyte mobo has both an AMD S750 and Gigabyte SATAII controller according to the manual.

    My issue:
    It always stalls, saying "ata1: softreset failed (device not ready)" or something about not being able find the DMA, depending on which distro I'm trying to install. Both errors seem to be an issue with the SATA HD.

    This seems to me an issue with the SATA controller or drivers. I don't think it's an issue with the setup, as I used the Ultimate Boot Disk and modified the partition on it, changing it to Ext2/3 and to FAT32, just to change things up. No problem there.

    Some deep googling found this bug report where they suggest that there is an issue with one of the controllers being compatible. I disabled it in the BIOS, no luck. Switched the disabled one (and the connection), no luck. I tried a number of kernel options that I found and that were suggested to me, including all_generic_ide, ide=nodma, acpi=off, noapic, nolapic. No difference.

    I ran a Western Digital quick media test on the hard drive from the Ultimate Book Disk and it came back fine. So the hard drive is being recognized, just not during the installation. I have the CDROM set to the first boot device and the hard drive as the second, but I think that's how it should be.

    Ideas? Could something be set up incorrectly in my bios? This is the first box I built, so something being set up wrong is not inconceivable.

  2. #2
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    1,183

    Default Re: System boots, but installation stalls

    So are you running you HDD in the Purple or yellow SATA plugs. You should be running it in the Yellow Plug Labled SATA0 and try with your DVD in SATA1. They are controled by the 790chip.
    Lian Li PC-7F Chassis Black
    Gigabyte GA-X48-DS5 MB (Rev. 1.1 BIOS v.F8c)
    Gigabyte ODIN GT 800Watt PSU
    Intel Core2Quad Q9550 E0 @ 3.4Ghz @ 1.25vcore
    Noctua NH-U12P + AS5
    G.Skill 2X2GB F2-8500CL5D-4GBPK
    2 X ATI Radeon HD4850 512MB (Crossfired)
    Dell Ultrasharp 2209WA IPS
    2 X 1TB Seagate 7200.11 in RAID 1
    Pioneer DVR216 SATA DVD MultiDrive
    Windows 7 Ultimate X64 RC1 (Build 7232)
    ------------------------------------------------
    Gigabyte Poseidon Chassis
    Gigabyte GA-EP45-DS3 (Rev. 1.0 BIOS v.F9)
    ASUS Artic Square CPU Cooling with AS5
    Thermaltake TR2 RX 550Watt PSU
    Intel Core2Duo E8500 E0 @ 3.8Ghz @ 1.25vcore
    Corsair 2 X 2Gb XMS2 PC6400C5 DDR2
    NVIDIA GeForce 8800GT 512MB
    1 X Seagate 1TB 7200.12 + Seagate 750GB 7211.11
    Sony SATA DVD MultiDrive
    Windows 7 Ultimate X64 RC1 (Build 7232)
    ------------------------------------------------

  3. #3
    Join Date
    Jun 2009
    Posts
    2

    Default Re: System boots, but installation stalls

    hi NimrodAUS

    i have tried both the yellow and purple with no luck. I currrently have the optical drive connected via IDE. I do not have an IDE-SATA converter, but that would not be impossible to acquire and use. Would that solve this issue?

    Thanks for your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •