Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: My Gigabyte 7600GS died! =(




  1. #1
    Join Date
    Aug 2009
    Posts
    2

    Default My Gigabyte 7600GS died! =(

    Mobo: GA-945G-S3
    Card: 7600GS 265MB

    Here's what happened:
    ..all of a sudden while browsing, my monitor went black for a few seconds and i heard a peep, and again goes black one more time with a few peeps! i turned my PC off from the power button and turned it on again, i found that some pixels are dead, some are very bright, some are dark, there's something wrong with the display in general! and computer doesnt go beyond the XP logo screen, then shows a black screen with the cursor on it! (i can access windows in safe mode, and i can access it too after uninstalling the driver in safe mode)

    What i have done:
    ..i tried to clean all the dust on my cpu/psu/video card, reseated my video card, nothing! i tested my monitor on my brother's PC, its working fine! i cant test the video card becoz his system doesnt have PCI-E! im currently using my onboard VGA and its working fine! i flashed the card's bios, i flashed my mobo's bios, nothing!

    ..could it be my mobo(i mean the PCI-E slot in my mobo), or is it the video card? also, can it be fixed?

  2. #2
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: My Gigabyte 7600GS died! =(

    Could either one or it could be the PSU. Deos the fan on the video card works?

  3. #3
    Join Date
    Mar 2009
    Location
    Earth
    Posts
    849

    Default Re: My Gigabyte 7600GS died! =(

    Can you try your brother's video card in yours? More likely than not it's the video card...

  4. #4
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: My Gigabyte 7600GS died! =(

    Yes, please try a different card to be sure but most likely it is the card that died

  5. #5
    Join Date
    Aug 2009
    Posts
    2

    Default Re: My Gigabyte 7600GS died! =(

    it doesnt have a fan, more like a heatsink sorta thing, something to dissipate the heat

    http://i.neoseeker.com/neo_image/152...card_thumb.jpg

    and i cant try it on my brother's pc becoz his sytem is old, doesnt support pci-e, and my system doesnt support AGP, will try it on a friend's pc soon, but no one ever experienced something like that? it was working like a charm for the past 18 months!

  6. #6
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: My Gigabyte 7600GS died! =(

    Ya you will need to find a system to test your card in, that's all you can do. Since it does not have a fan and only a heatsink it likely was hot for too long and fried

    Get one with a fan this time around and it should last longer

  7. #7
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: My Gigabyte 7600GS died! =(

    My card black out every now and then, but only for a secont or two, nothing severe like yours.
    Did it on my ASUS P35 board so it must be the card, the driver, or monitor.

  8. #8
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: My Gigabyte 7600GS died! =(

    I would suspect from his comments the card died. I have never liked passive heatsink GFX Cards because the only tend to run hot or overheat too often

  9. #9

    Default Re: My Gigabyte 7600GS died! =(

    i7 930 @ 4.2 ghz (200x21) 1.34 vcore 1.33 qpi
    Noctua U12P se1366 Push Pull w/scythe slipstreams
    6GBOCZ1333 @ 1600 - 9 9 9 24 1.64v
    Gigabyte EX58-UD3R f11
    Corsair tx750 PSU
    EVGA GTX260 SC
    Intel SSD80GBG2C1 OS/Apps
    WD Caviar Black 500gb Data
    ASUS Xonar DX
    Klipsch Promedia 2.1
    CM690 Case 3 in 3 out
    Windows 7 64bit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •