Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: GA-G31M-ES2L PC/System/mobo speaker problem!




  1. #1
    Join Date
    Oct 2009
    Location
    India
    Posts
    3

    Default GA-G31M-ES2L PC/System/mobo speaker problem!

    Hello,

    Last week I change my old mobo with Gigabyte(GA-G31M-ES2L) mobo.
    Everything seems fine, but I recently found that the PC speaker(i.e. the System speaker) is not working at all .

    My antivirus beeps through system-speaker whenever it founds anything, thats how I find the speaker is not working.

    In other words
    Code:
    printf("\a");
    produce no bell.

    Any clues... please ....

  2. #2
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-G31M-ES2L PC/System/mobo speaker problem!

    What is printf("\a"); ?

    Do you have the speaker connected properly? Did you try to reverse it and see if it then makes a beep?

    You should hear one beep everytime you start the system after the POST, so if you hear a beep then it is working

  3. #3
    Join Date
    Oct 2009
    Location
    India
    Posts
    3

    Default Re: GA-G31M-ES2L PC/System/mobo speaker problem!

    Hello thanks for responding :)

    No there is no beep after POST.
    After reading your post, I look into the mobo manual and then open my case and found that there are actually no wire connected to the speaker pins.

    power led, reset swith etc. are connected, but not the speaker pins.

    Infact there are no wire to connect to it.

    So I think I need to buy a small PC speaker and then connect it to the pins (i think my old mobo must had an in-built speaker), right?

    BTW, printf("\a"); is a c-code, when excuted it should produce a "beep" from the speaker.
    Last edited by playwin2; 10-17-2009 at 02:14 AM.

  4. #4
    Join Date
    Oct 2009
    Location
    India
    Posts
    3

    Default Re: GA-G31M-ES2L PC/System/mobo speaker problem!

    Okay, I attached a tiny pc-speaker to the pins, and it's working.
    Thread solved. Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •