Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: GA-P35 DS3P DPC latency




  1. #1
    Join Date
    Dec 2008
    Posts
    60

    Default GA-P35 DS3P DPC latency

    hi i have been running my GA-P35 DS3P with a q6600 @3ghz
    for some time now (over a year) I have used windows xp I have always had EIST and c1 and never had any dpc latency problems at all (I would notice right away if I did to using the pc for Guitar-rig)


    I have moved to windows 7 and right away after clean install I started getting DPC spikes

    done all the normal testing closing devices from the device manager
    and found nothing there

    I have since found the problem to be EIST as soon as its off I have no DPC problems... what I cant understand is why when it worked fine under XP
    and not windows 7 I have the latest chip-set drivers and still the same

  2. #2
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: GA-P35 DS3P DPC latency

    Quote Originally Posted by sniperdude View Post
    hi i have been running my GA-P35 DS3P with a q6600 @3ghz
    for some time now (over a year) I have used windows xp I have always had EIST and c1 and never had any dpc latency problems at all (I would notice right away if I did to using the pc for Guitar-rig)


    I have moved to windows 7 and right away after clean install I started getting DPC spikes

    done all the normal testing closing devices from the device manager
    and found nothing there

    I have since found the problem to be EIST as soon as its off I have no DPC problems... what I cant understand is why when it worked fine under XP
    and not windows 7 I have the latest chip-set drivers and still the same
    ive found if you disable c1e and use balanced power option in win7 it will do the same job as c1e in the bios but without the dpc noise,eist didnt fix it for me it was c1e that was causing it
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Join Date
    Dec 2008
    Posts
    60

    Default Re: GA-P35 DS3P DPC latency

    really strange, you saying that give me an Idea

    when I has EIST enabled for some reason I was unable to change power settings in 7

    I would change it from balanced or even just edit the balanced profile
    click OK and then go back and the changes I had made would be gone
    and it would be back to default balanced settings


    since you said that I thought I would have another go with the power settings

    with EIST disabled I was able to change the power setting to performance
    and the saved ok, then I went into the BIOS and enabled EIST again and the performance setting is still saved

    now I have EIST and C1E enabled with no effect on DPC

    clearly the default power settings in win7 have a huge effect on DPC with EIST enabled

    also I have noticed the HPET BIOS setting has an effect on DPC too

    on the default power settings without EIST or HPET enabled
    my DPC times in would be anything from about 7us to 20us (very low)

    with HPET enabled it goes up to about 117us to 170us

    with performance power setting enabled with C1E and EIST on right now I am getting the same 117us to 170us and am happy with that.

  4. #4
    Join Date
    Dec 2008
    Posts
    60

    Default Re: GA-P35 DS3P DPC latency

    i have set everything in the performance profile to the balanced settings apart from Processor Power Management its fine still

  5. #5
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: GA-P35 DS3P DPC latency

    Quote Originally Posted by sniperdude View Post
    i have set everything in the performance profile to the balanced settings apart from Processor Power Management its fine still
    have you disabled c1e now in the bios? as it will still throttle the cpu when at idle if win7 balanced is enabled,and it might lower dpc even more
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  6. #6
    Join Date
    Dec 2008
    Posts
    60

    Default Re: GA-P35 DS3P DPC latency

    in my case C1E on or off isnt making any difference to DPC

    if i turn off HPET my DPC latency drops to about 7us to 20us
    with my current power settings and with c1e enabled and EIST enabled


    am happy getting 117us to 170us with c1e, EIST and HPET enabled

    if I go to the balanced settings I get huge 4000us spikes think the reason for this is Processor Power Management

  7. #7
    Join Date
    Apr 2009
    Location
    J'Habite En Angleterre
    Posts
    2,431

    Default Re: GA-P35 DS3P DPC latency

    You are not alone in getting higher DPC latencies with Windows 7. I've seen the same thing on my board. With Xp and a mechanical drive for the OS I get a maximum (after 20 min light usage or so) of 93us latency. The exact same system with Windows 7 installed and latencies hit ~370us. OFC, for my usage patterns this represents no problem, either way audio is lag and jitter free etc. If I were an audiophile and into editing though, I'd be disappointed with my results there.

    Funnily enough, since switching to RAID Corsair X32 SSD's (Indilinx Barefoot), my latencies have fallen quite sharply in Windows 7 to a peak of around 100us. XP has dropped too with spikes to a whopping 30us and a tick over of around 14us or so, which I believe is rather excellent (not really up on DPC latency in a big way).

    The latency spikes can be heavily influenced by kernel mode drivers. As Win 7 has a redesigned kernel and a different driver implementation completely, I can understand latencies being different but am disappointed for some people who seem to unfortunately have problems.

    The only things I can suggest are:

    Go through the Integrated Peripherals section of the BIOS and disable EVERYTHING you don't use. it helped me greatly to disable the Gigabyte (JMicron) Purple SATA ports, the Serial and parallel headers, one of my two NIC's and my Firewire/IEEE1394.

    Having the IDE ports "Ports 0-3 native mode" set to Disabled meant that there was less dynamic swapping of IRQ's due to the SATA controller being assigned a static set of IRQ's by the BIOS. In Native mode it's the OS that has free will over IRQ settings here.

    The last decrease in latency came for me, from uninstalling any hidden/non present/defunct devices in device manager. Open a Command window with admin privilages (applies to Vista and 7, right click > run as admin) and type (without the quotes) "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" and hit enter. You must keep this command window open and now open up Device Manager. In the View menu select show hidden devices. Now go through each catagory, expanding and searching for "ghosted out" device names, these are translucent. Many can be safely deleted. Note that if you're not brave enough to delete the ones in System Devices, then by all means leave them. Also I recommend you don't remove anything that calls itself a "Shadow Copy", for obvious reasons. You will also notice some entries for removable devices you may use like a USB stick or external HDD, microphone etc. You can delete these of you like, but they'll only get recreated next time you use the device, plus you'll now be subjected to the "Searching for a driver" rigmarole. Best leave these alone too IMO.

    Those steps won't work miracles, but in my case latency wasn't really screwy any way. Maybe on a system with a bad latency problem, the effects of these "tweaks" will be magnified to become more significant.
    Coolermaster CM 690 II advance Case
    Corsair HX750 (CWT, 91%(80+ Gold rated @230V) single 62A 12V rail
    P55A-UD4 v2.0 @ F14
    Core i5 760 @ 20 x 201, 4.02GHz
    TRUE Black with a single Noctua NF-P12 pumping out 55 CFM @ 19db .
    2 x 2GB Mushkin Ridgeback (996902), @ 7-10-8-27, 2010-DDR, 1.66v
    2 x Gigabyte GTX 460 1024MB in SLI (Pre OC'd to 715MHz core and 1800MHz VRAM) @ 850 Core / 4100 Mem.
    Intel X25-M Boot Drive (OS and Programs) 200MB/s Read & 90MB/s Write
    Corsair X32 200MB/s Read & 100MB/s Write
    WD Caviar Blue 640GB C (Steam, Games, Storage, Temp Files & Folders, etc)
    Samsung F3 500GB Backup/Images
    Noctua 1300RPM 19dB case fan (rear extraction)
    3 x 140 MM Coolermaster LED fans (one front intake, one top extraction, one side intake)
    Dell Ultra Sharp 2209WAf E-IPS @ 1680x1050

  8. #8

    Default Re: GA-P35 DS3P DPC latency

    Its funny that I'm having this issue now after not having it before. I went from Vista w/o the issue to reloading Vista with the issue to doing a clean Win 7 install still having the issue.

    I think it may be from switching from raid0 with ACHI to not using ACHI w/o raid. I have read a bit on this topic but thinking its my issue. All previous setups had C1E and EIST on, just changed HPET and dont think that was it(turned it On currently)
    New Q9650, Gigabyte UD3P, 4GB OCZ Platinum, Asus TOP 4850, Antec TP3 550W, Vista 64 SP1/XP SP3.

    http://www.cardomain.com/ride/2641801

  9. #9
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: GA-P35 DS3P DPC latency

    Quote Originally Posted by SpeedEuphoria View Post
    Its funny that I'm having this issue now after not having it before. I went from Vista w/o the issue to reloading Vista with the issue to doing a clean Win 7 install still having the issue.

    I think it may be from switching from raid0 with ACHI to not using ACHI w/o raid. I have read a bit on this topic but thinking its my issue. All previous setups had C1E and EIST on, just changed HPET and dont think that was it(turned it On currently)
    have you tried with c1e off? and select balanced setting in win7 power saving options
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  10. #10

    Default Re: GA-P35 DS3P DPC latency

    Sorry for the late reply, been busy. But This weekend it was bad and driving me crazy.

    Turned DES off and its perfect. Turned it back on and still good for a short period then back to getting worse.

    Actually now that I watch the DES screen i get clicks/static everytime the DES switches "Phases" from 2-3 for me anyway

    WTF??
    Last edited by SpeedEuphoria; 03-12-2010 at 08:30 AM.
    New Q9650, Gigabyte UD3P, 4GB OCZ Platinum, Asus TOP 4850, Antec TP3 550W, Vista 64 SP1/XP SP3.

    http://www.cardomain.com/ride/2641801

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •