Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: Enabling CrossfireX on GA-EP45-UD3P




  1. #1
    Join Date
    Jan 2010
    Location
    US
    Posts
    3

    Default Enabling CrossfireX on GA-EP45-UD3P

    Does anyone know how to enable this?

    I have a pair of HD 4770s and the PC does not recognize crossfire. On CCC, there are no options for Crossfire either.
    I have both X-fire bridges installed and still nothing.
    Any helpful advice would be appreciated.

    Thanks.

    Q9550
    GA-EP45-UD3P revision 1.0 (BIOS F9)
    8GB DDR2 PC800
    PC Power & Cooling Silencer 750W

  2. #2
    Join Date
    Nov 2007
    Location
    Australia
    Posts
    286

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    Can you see the cards in device manager? Are the 6-pin PCI-e power connectors connected?
    Asrock P55-Extreme
    Core I5 @ 3.2GHZ
    2x2GB G.skill Ripjaws DDR3 1600
    ASUS HD5850
    1TB Samsung SATA II
    Corsair TX650W PSU

  3. #3
    Acebmxer's Avatar
    Acebmxer is offline Gigabyte Elite
    Join Date
    May 2009
    Location
    New Jersey, United States
    Posts
    2,817

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    its a Driver issues as long as you have check to make sure both cards installed correctly and power is plugged in.

    Some people have had to uninstall the drivers. Shut down remove the card from the second slot boot into safe mode run driver sweeper reboot install drivers 9.12 reboot finish booting to desktop. Shut down install second card + xfire bridge. Boot back up install drivers again reboot then enable x-fire.. this was something i read on another forum. I dont have xfire so cant say for sure.
    Main Rig
    Gigabyte z87x-OC
    Haswell i7 4770k - 4.7Ghz @ 1.330v LLC Extreme (L310B492)
    G.Skill F3-1700CL9D-8GBXM DDR3-2133mhz 9-11-10-28 1.65v @ 2800mhz 12-14-14-35 1.7v
    Samsung Green 8GB 2x4GB MV-3V4G3D/US DDR3 1.3v 30nn @ 2200Mhz 11-11-11-32 1.60v
    Sapphire ATI HD 7970 3GB clocked 1200MHz @ 1.181v.
    HiS ATI HD 6950
    Samsung 840 Pro 256GB SSD (boot Drive) on Intel sata3 controller port0
    Corsair Force GT 120 GB Sata3 SSD on Intel sata3 controller port1
    Samsung 320GB HD322GJ 7200 RPM 16M cache on Intel sata3 controller port2
    Sony Optiarc DVD-RW AD-7240S on Intel sata3 controller port5
    CORSAIR CMPSU-850TX PSU
    Swiftech MCP655-B Pump
    EK Supremacy Cpu Block
    Swiftech Mcres Micro Rev 2 Reservoir
    Black Ice GTX Xtreme 360 Radiator





  4. #4

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    I recommend you -

    1. Download Catalyst 9.9 Drivers (techPowerUp! :: Downloads) - More on why 9.9 here in a minute.
    2. Download Driver Sweeper (Guru3D - Driver Sweeper)
    2. Uninstall your current Catalyst Software Drivers.
    3. Reboot.
    4. Boot into safe mode, and run Driver Sweeper
    5. Reboot once again
    6. Install Catalyst 9.9
    7. Reboot
    8. Upon login you should see Catalyst Control Center open with the Crossfire tab open. (It does for me, I've done this sequence damn knows how many times on my system.)

    I get the best performance all around with Catalyst 9.9 drivers. Anything newer and I get severe stuttering in Crysis / Crysis Warhead. I know that certain drivers are better for certain games, and while newer drivers may give more performance in some games, they can take away performance in other games. I mainly play Crysis, and Source games and I can tell you I get the best performance from Catalyst 9.9

    Other than the recommended sequence above, you might try making sure your crossfire bridge(s) are connected. I personally recommend more than 1 bridge. In all the benchmarks I have done, I see a slightly higher minimum frame rate with 2 bridges.

    If this doesn't work, what does GPU-Z report?

  5. #5
    Join Date
    Jan 2010
    Location
    US
    Posts
    3

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    Greetings and thanks to everyone's input so far.

    I took your advice and tried re-installing CCC 9.12 along with the 2nd card itself. Unfortunately, this did not work.

    I've also tried the CCC 9.9 and this did not work either.

    For both methods, I've used Driver Sweeper (guru3d).

    I have both X-fire bridges installed. GPU-Z does not have Crossfire enabled and only recognizes one 4770. CCC 9.9 does not have a crossfire option listed.

    It's odd because I've installed this X-fire configuration on a different machine (i7 920/6GB DDR3 PC1600/Corsair 850HX) with no problems.

    By the way, the two GPUs in question are XFXs.

  6. #6

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    What OS are you using? Have you tried other BIOS or the new beta BIOS for you UD3P 1.0? New beta BIOS is F10f (2009/08/25) for your UD3P and revision number.

    Just a thought... is the fan spinning on the card that your display isn't hooked up to? I think if the 6-pin power connector isn't plugged into your card it would let you know real quick, someone correct me if I'm wrong. I haven't ever forgotten to plug the 6-pin in with these, but I have with cards in the past, and the system won't even POST.

  7. #7
    Join Date
    Jan 2010
    Location
    US
    Posts
    3

    Default Re: Enabling CrossfireX on GA-EP45-UD3P

    The OS I'm using is WIN7 HP x64. The BIOS is F9 and I didn't install the F10 because it states it's a beta and did not know how stable it will be. It's quite odd as stated before...my set up is almost exactly the same as yours. Q9550 E0 (running stock clock) Corsair XMS DDR2 PC800 8GB This "great MB working flawlessly until now...with this X-fire thing" PC PWR 750W (I Don't think it's the PSU...I think it's enough for this set-up) 2 ea. optical drives 1 ea. WD caviar BLK 1TB Yes, Both 6-pin connectors are plugged in. The fan on the second 4770 is spinning along with the first one. I think I'll try the F10 BIOS tomorrow, but I get the feeling that it will do nil. I really appreciate your input. I truly mean this!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •