Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: GA-P55A-UD4P and Marvell 91xx Config ATA Device




  1. #1
    Join Date
    Jan 2010
    Location
    USA
    Posts
    7

    Default GA-P55A-UD4P and Marvell 91xx Config ATA Device

    I'm running Windows 7 x64. I have installed all the drivers from Gigabytes website (except Intel raid and inf).

    My issue is with the Marvell 9128 chip. I do not have any drives connected to SATA3_6 or SATA3_7. However, the "Marvell 91xx Config ATA Device" appears in the Safely Remove Device dialog box in the system tray and in Devices and Printers.

    According to Microsoft (Internal and External SATA Port Configuration) this is an indication that Windows thinks the internal SATA ports are external.

    First, has one one else seen this issue?
    Second, is there a fix?

    Thanks.

    -Gak Toid

  2. #2
    Join Date
    Oct 2009
    Posts
    37

    Default Re: GA-P55A-UD4P and Marvell 91xx Config ATA Device

    "Marvell 91xx Config ATA Device" appears in the Safely Remove Device dialog box in the system tray and in Devices and Printers. --> I dont have this message and I dont have any drive on SATA3_6 and 7.
    I've installed INF and all drivers from driver DVD with xpress install.
    what is your bios setting? (my bios settings are remained as default, except setting memory to 1600.)
    can you provide the picture for that?

  3. #3
    Join Date
    Jan 2010
    Location
    USA
    Posts
    7

    Default Re: GA-P55A-UD4P and Marvell 91xx Config ATA Device

    Most of my BIOS settings are at default. I think the important one that I changed was I set all the SATA controllers to RAID mode.

    I don't believe this is a BIOS issue, although it could be related.

    In the Device Manager it shows that the 'Marvell 91xx Config ATA Device' has the "Capability" set to "Removable" (CM_DEVCAP_REMOVABLE [0x00000004] from cfgmgr32.h). This setting resides in the registry, but I believe it is set by the driver.

    -Gak Toid

  4. #4
    Join Date
    Mar 2010
    Location
    uk
    Posts
    1

    Default Re: GA-P55A-UD4P and Marvell 91xx Config ATA Device

    Hey, i have the same device problem but 1 difference, it doesn't want to be removed. Its just registered as an unknown device.

    I think its a windows 7x64 bit error, i can't seem to find the problem but its something to do with not recongising the drivers or the device.

    I have the problem for the marvell and a Universal serial bus controller so it makes my usb devices work intermitently.

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P55A-UD4P and Marvell 91xx Config ATA Device

    Make sure you install the latest Intel INF Chipset installer
    http://downloadcenter.intel.com/Prod...?ProductID=816

    Then for your Marvell issue you need to install both of these drivers (Last two in SATA)
    GA-P55A-UD4P (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - Driver

    Then this firmware update for USB 3
    http://www.gigabyte.com.tw/FileList/...02108FWUP5.zip

    And then the last driver on the Gigabyte page above, the USB 3 driver
    GA-P55A-UD4P (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - Driver

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •