the multi will stay at 21 if you disable c1e and eist...altho i keep them enabled so it saves heat at idle and only goes to 3.8 when under any load,your settings look fine to me,you should be able to clock to 3.8ghz with 1.3v qpi..go in win7 power saving and select high performance to keep full clock speed,balanced will reduce it when cpu is idle but not at load