Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: SATA Drives Showing Up IDE in BIOS




  1. #1
    Join Date
    Mar 2010
    Location
    California
    Posts
    5

    Default SATA Drives Showing Up IDE in BIOS

    Guys, need your help here. I'm a relative noob but am on my 3rd machine. In this computer, I'm using the Gigabyte EP45-UD3P motherboard, an Intel Q9600 (core 2 quad), Corsair Dominator (4GB, 1066), and an old Nvidia 8800 GTS video card. PSU is Seasonic 750W, OS is Win 7 Pro 64 Bit... Here's my situation/question: I took this mobo from another machine that had 2 sata hard drvies and one PATA optical drive and scrapped that machine for parts. As a result, I then installed the mobo in a completely new machine and set it up from scratch. Boot drive is a Corsair 60GB Reactor SSD drive (sata of course) and a new lite-on SATA optical drive. Now for the challenge/confusing part. I think I must have done something wrong in how I initially setup the machine, because all my drives are showing up as IDE in my BIOS. When I go into BIOS, it lists the drives in teh whole "master/slave" arrangement. I fear I need to start from scratch, reset my BIOS/CMOS before installing my drives and OS, but is there anything I'm missing here? Does it really not matter? My 'windows experience' shows my drive delivering a 7.0, so the transfer speeds are okay... Part of me just wants it done right, regardless of whether it's working fine now. Any suggestions from this esteemed group? Thanks in advance!

  2. #2

    Default Re: SATA Drives Showing Up IDE in BIOS

    The board does have more than two SATA connectors. Which ones do you use?

    The ICH10R (if you do use its connectors) does have three modes: IDE, AHCI, and RAID. Which one did you choose?

  3. #3
    Join Date
    Mar 2010
    Location
    California
    Posts
    5

    Default Re: SATA Drives Showing Up IDE in BIOS

    I used Sata port 0 for the boot drive (I think it was actually labeled Sata2_0) and port 1 (Sata 2_1) for the optical drive. I did not initially select anything in BIOS when I setup the machine. The other 2 machines I built were on EVGA X58 boards and they automatically defaulted or picked up the fact I had installed sata drives. So when I set up this machine, I didn't make any changes to the BIOS settings, which is how I think I got myself into this problem. It sounds like I should have installed all the hardware, booted up w/out an OS, gone into BIOS, selected the right settings (e.g. AHCI instead of IDE), and then install the OS from there. With all that said, if I'm correct, is there any way of changing this now that I installed everything? Or do I need to start from scratch with a clean re-install? Thanks for your help.

  4. #4
    Join Date
    Apr 2009
    Location
    Virginia
    Posts
    1,470

    Default Re: SATA Drives Showing Up IDE in BIOS

    Maybe this will help.
    The SATA2 controller is working as it should be.
    SATA Revision 2.0 (SATA 3Gb/s)
    First-generation SATA devices often operated at best a little faster than parallel ATA/133 devices. Subsequently, a 3 Gbit/s signaling rate was added to the physical layer (PHY layer), effectively doubling maximum data throughput from 150 MB/s to 300 MB/s. Please note that the correct translation into MBytes is roughly 148 MB/s and 286 MB/s, without overhead encoding, but for brevity is rounded up.
    For mechanical hard drives, SATA 3 Gbit/s transfer rate is expected to satisfy drive throughput requirements for some time, as the fastest mechanical drives barely saturate a SATA 1.5 Gbit/s link. A SATA data cable rated for 1.5 Gbit/s will handle current mechanical drives without any loss of sustained and burst data transfer performance. However, high-performance flash drives are approaching SATA 3 Gbit/s transfer rate.
    More on this ----> Serial ATA - Wikipedia, the free encyclopedia

    By default the SATA2 controller will be in IDE mode. In IDE mode it is still a SATA2 transfer rate of 3GB's maximum. If you want AHCI or RAID you need to change the Integrated Pereperals settings in BIOS. With a single HDD you only have 2 choices. IDE mode or AHCI mode. In your BIOS you would have to navigate to Integrated Peripherals make the change then install the AHCI drivers.
    Code:
    Integrated Peripherals
    SATA RAID/AHCI Mode [Disabled]Changed here
    SATA Port0-3 Native Mode [Disabled]
    USB Controller [Enabled]
    USB 2.0 Controller [Enabled]
    USB Keyboard Support [Enabled]
    USB Mouse Support [Disabled]
    Legacy USB storage detect [Enabled]
    Azalia Codec [Auto]
    Onboard H/W 1394 [Enabled]
    Onboard H/W LAN1 [Enabled]
    Onboard H/W LAN2 [Enabled]
    Green LAN [Disbabled]
    �� SMART LAN1 [Press Enter]
    �� SMART LAN2 [Press Enter]
    Onboard LAN1 Boot ROM [Disabled]
    Onboard LAN2 Boot ROM [Disabled]
    Onboard SATA/IDE Device [Enabled]
    Onboard SATA/IDE Ctrl Mode [IDE]
    Onboard Serial Port 1 [3F8/IRQ4]
    Onboard Parallel Port [378/IRQ7]
    Parallel Port Mode [SPP]
    With a single HDD you only have 2 choices. IDE mode or AHCI mode. I could'nt tell the difference from those 2 modes. When I switched from IDE to AHCII had to install a clean OS and use the F6 option to install the AHCI drivers with no true benefit for me. It's up to you.
    Last edited by artdrivers; 03-24-2010 at 08:40 AM.
    http://forums.tweaktown.com/gigabyte...ench-test.html
    http://www.gigabyte-usa.com/FileList...ios_qflash.pdf
    Phenom II 945 @ 3.2Ghz w/Thermaltake Big Typhoon Pro 14 CPU Cooler
    Gigabyte GA-MA78GM-S2H rev.1.1 F11
    Sapphire 3870HD / 100225L / 512MB / ddr4
    4GB / Kingston / KHX8500D2K2/2GN / 5-5-5-18 / 1066Mhz
    (2) WD Caviar / WD2500AAKS/ 250GB in SATA RAID-0
    (1) WD Caviar / WD2500AAKS/ 250GB in SATA AHCI
    (2) IDE's 1 8XdualDVDRW 1 52x32x52x CDRW
    Antec /Neo HE550 / 550W
    Mid size ATX case with show through panel
    2) 80x80 front fans (1) 120x120 rear fan and small nb fan
    Microsoft comfort curve USB keyboard 2000 ver.1.0
    Logitech G500 USB mouse
    Monitor: CMV937A
    7.1+2 Channel High Definition ALC889A
    Dual boot Windows 7 32bit home & Windows 7 64bit home


  5. #5
    stasio's Avatar
    stasio is online now GIGABYTE Elite
    Join Date
    Oct 2007
    Location
    My
    Posts
    5,688

    Default Re: SATA Drives Showing Up IDE in BIOS

    When you switched from IDE to AHCI in the BIOS,you no need to install a clean OS .
    Use hack described here:
    http://forums.tweaktown.com/f69/welc...tml#post346413
    GA-Z170X-SOC Force , Kaby Lake...
    GA-Z97X
    -SOC Force ,
    Core i7-4790K @ 4.9 GHz
    GA-Z87X-UD3H ,Core i7-4770K @ 4.7 GHz
    G.Skill F3-2933C12D-8GTXDG
    @ 3100 (12-15-14-35-CR1) @1.66V
    2xSSD Corsair Force GS 128 (RAID 0), WD Caviar Black SATA3 1TB HDD,
    Evga GTS 450 SC, Gigabyte Superb 720W
    XSPC RayStorm D5 EX240 (Liquid Ultra)
    NZXT Phantom 630 Ultra Tower
    Win 7 SP1 x64;Win 8.1 x64;
    Win 10 x64

  6. #6
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: SATA Drives Showing Up IDE in BIOS

    So is this all straightened out now?

    IDE showing in BIOS is normal, this is just how Gigabyte chose to label things. The drives will not be running as IDE drives, speed-wise, this name just differentiates the mode apart from AHCI or RAID mode.

    Please put your OS Drive on SATAII_0 as you have it, and your DVD Drive on SATAII_5. This will ensure that you do not have any future issues

  7. #7
    Join Date
    Mar 2010
    Location
    California
    Posts
    5

    Default Re: SATA Drives Showing Up IDE in BIOS

    Thanks for all your input, guys. I'm back at work and will try this out tonight. Will report back how this works out ASAP.

  8. #8
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

  9. #9
    Join Date
    Feb 2010
    Location
    Birmingham,Great Britain
    Posts
    600

    Default Re: SATA Drives Showing Up IDE in BIOS

    its very easy to enable ahci in win7 if you want to make the switch without re-installing too,i havent long done the reg tweak myself although i didnt notice any speed increase
    Gigabyte ex58-ud5 f12 bios
    Intel i7 920 d0 @3.8ghz 24/7-normal cpu voltage 1.18750v/c1e/turbo/multi threading enabled
    Ocz reaper DDR3 PC3-14400 (1800MHz) 3x2gb (OCZ3RPR1800LV6GK) 8-8-8-24-1t-@1.64v-1.3qpi
    Thermolab Baram cpu cooler
    Dual Boot
    1xsamsung 750gb hard drive-win7 ultimate 64
    1xsamsung 750gb hard drive-windows xp pro 32
    Ati x1950 pro gpu
    Logitech X-530 5.1 Speakers
    1050w psu
    Nzxt lexa case
    http://i40.tinypic.com/2z3w377.jpg <=3.8ghz overclock template

  10. #10
    Join Date
    Mar 2010
    Location
    California
    Posts
    5

    Default Re: SATA Drives Showing Up IDE in BIOS

    I followed the instructions posted by Stasio (welcome to gigabyte forums link) and it worked. The drives were immediately recognized, drivers were installed, and now are showing up as SATA. Next up, I will try the eSata port to see if the "hot-swappable" feature of AHCI is working. I haven't noticed a change in speed either, but am happy it's done the right way now.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •