Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: GA-M55plus-S3G flashed with wrong BIOS




  1. #1
    Join Date
    May 2010
    Location
    USA
    Posts
    1

    Default GA-M55plus-S3G flashed with wrong BIOS

    Hi all,

    I have a GA-M55plus-S3G rev. 1 mobo. When I used @BIOS the program detected my mobo as a rev. 2, and flashed rev. 2's latest stable (not beta) firmware on my board. I didn't know any better not to trust the program at the time.

    My system now freezes when I try surf the web with Chrome (but not Firefox), and download using uTorrent. I don't know what went wrong, so I suspect that the wrong BIOS is at fault.

    I tried to reflash using the correct rev. 1 BIOS (F15b), but I have no success. I tried @BIOS via file, flash895 via USB, and How to Qflash guide without luck. I keep getting similar error messages that says "BIOS ID check error" with those above options.

    Is there something I can do to reflash the BIOS from the wrong rev. 2 BIOS to the right rev. 1 BIOS?

    Thanks in advance.

  2. #2
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-M55plus-S3G flashed with wrong BIOS

    With the current incorrect BIOS, did you load optimized defaults and set your memory voltages, ect after the flash? Just checking.

    Yes, I can PM you a tool to flash the correct BIOS in, but you must not share the tool or post it anywhere. And you have to accept the fact that if the flash fails neither I nor GIGABYTE is to blame. That's just the usual fine print is all, no worries if you flash safely/properly.

    The tool is directly from GIGABYTE and allows you to flash any BIOS into any board, which would be what you need to do to get around the BIOS ID Check.

    If you need it send me a PM, you will need a bootable USB Stick that you know works and you have ran DOS from, or a floppy, or anything you can run DOS from. I assume you have this anyway since you tried via flash895/USB.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •