Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: SATA Port 0-3 Native Mode




  1. #1
    Join Date
    Jan 2010
    Location
    Newegg
    Posts
    31

    Default SATA Port 0-3 Native Mode

    What is the recommended settings to use with "SATA Port 0-3 Native Mode"
    It is disabled by default ~ My current Sata drivers are set to IDE mode in bios, so it is ok to enable this setting? and if I change my IDE mode to AHCI mode, I enable or disable SATA Port 0-3 Native Mode?
    i7 920 D0 | UD7 F7r MOD | 6GB Corsair Dominator GT 1600 7-7-7 | HD4890 | WD 1TB | Antec Quattro 850w

  2. #2
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: SATA Port 0-3 Native Mode

    its something to do with sharing irq's with other devices,set to disabled for os's that dont support native mode,set to enabled to enable native ide mode for os's that support it

    BIOS Settings for Native-Mode-Capable ATA Controllers
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Join Date
    Jan 2010
    Location
    Newegg
    Posts
    31

    Default Re: SATA Port 0-3 Native Mode

    Thank you wazza300 for the helpful site, I'm using windows 7 so I will keep it enabled.
    But on my next windows reinstall, I'm going to switch to AHCI, I still leave it enabled or set it back to disabled?
    i7 920 D0 | UD7 F7r MOD | 6GB Corsair Dominator GT 1600 7-7-7 | HD4890 | WD 1TB | Antec Quattro 850w

  4. #4
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: SATA Port 0-3 Native Mode

    keep enabled i think,i have mine set to enabled,i think its only disabled as default for when you install the os and no sata drivers are present,then you can enable it later
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: SATA Port 0-3 Native Mode

    If you want to switch to AHCI you don't need to do a clean install, unless you wanted to. You can make the following registry changes, then enable Native mode and AHCI once you have done these changes


    Win7 / Vista ONLY!

    Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0
    Code:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide\Start  
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV\Start

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •