Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Issue with ACHI




  1. #11
    Join Date
    Sep 2010
    Location
    California
    Posts
    262

    Default Re: Issue with ACHI

    ^Oops. I forget that not everyone uses the same setup as I do. I always use at least two harddrives on my system, one for my os and programs and others for my files and data. If you have important files you want to save, you can install without formatting, in which case, your old files will be saved and will be accessible by your new OS installation. But I wouldn't suggest this.

    Make sure you are working in your original setup--for example, by reverting to IDE--before trying to access Windows.

  2. #12
    Join Date
    Oct 2010
    Location
    hong kong
    Posts
    5

    Default Re: Issue with ACHI

    hi all, i tried changing to another BIOS file(overwiriting the DMI pool data) and it can boot with AHCI at first. i thought it finally fix the problem but the same disk read error occurred after i reboot :(

    maybe is it something relating to the DMI pol data??

  3. #13
    Join Date
    Sep 2010
    Location
    California
    Posts
    262

    Default Re: Issue with ACHI

    I don't think you have a hardware issue. I think you did something wrong. Your computer is probably fine. I think this because you said your system was fine under IDE mode. What you have to do to prepare Windows for AHCI is first to go back into IDE mode. Did you do this? Only then can you access Windows and your harddrive. If you have tried to REPAIR Windows or changed other BIOS settings while under AHCI mode and before you prepared Windows for the change then you may eventaully want to reinstall Windows. You say that you cannot access your Windows disc on your optical drive. Is your optical drive IDE or SATA? If it is SATA, which SATA port (0-9) did you plug it in?

  4. #14
    Join Date
    Oct 2010
    Location
    hong kong
    Posts
    5

    Default Re: Issue with ACHI

    Quote Originally Posted by ROSESTEEL View Post
    I don't think you have a hardware issue. I think you did something wrong. Your computer is probably fine. I think this because you said your system was fine under IDE mode. What you have to do to prepare Windows for AHCI is first to go back into IDE mode. Did you do this? Only then can you access Windows and your harddrive. If you have tried to REPAIR Windows or changed other BIOS settings while under AHCI mode and before you prepared Windows for the change then you may eventaully want to reinstall Windows. You say that you cannot access your Windows disc on your optical drive. Is your optical drive IDE or SATA? If it is SATA, which SATA port (0-9) did you plug it in?
    i did go back to IDE mode and install the AHCI dirver and modify the registry. but still the same. i thought there may be some problem with the WIN 7 installation so i also tried installing WIN7 again with another formatted harddisk in AHCI mode. As i said i can't access my optical drive(it's a SATA drive and i tried different ports already) using the intel SATA in AHCI, so i plug it into the Gigabyte port (the port is configged as AHCI also). the installation runs well but the disk read error occured again and again everytime in the first reboot after installation.

    what i don't understand is that why i can boot in Windows in AHCI mode right after i changed the BIOS but failed afterwards?

  5. #15
    Join Date
    Sep 2010
    Location
    California
    Posts
    262

    Default Re: Issue with ACHI

    When trying to boot from optical drive, did you make sure that you selected boot from cd-rom option?

    Also, have you overclocked?

    In Standard CMOS Features, is the time correct?

    Is SATA Port0-3 Native Mode DISABLED?

    Is HPET Mode in 64bit?

    Can you confirm that SATA cables are properly plugged in?

  6. #16
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Issue with ACHI

    Some CD/DVD drives don't work in AHCI mode (LG is one culprit).

    Plug your CD/DVD drive into SATAII-4 or 5, and then connect your OS hard drive to SATAII_0

    Install in IDE mode, with NO Drivers during or after the install. Then make the following registry changes and reboot to the BIOS.

    Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0
    Code:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide\Start  
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV\Start
    Once in the BIOS enable AHCI and you will be good to go.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •