Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Having trouble connecting online Error Code 31




  1. #1
    Join Date
    Nov 2010
    Location
    new jersey
    Posts
    2

    Default Having trouble connecting online Error Code 31

    I have a built computer and I cant seem to connect online. This problem happened after I kept unplugging in and out the ethernet cable. could I have damaged the ethernet port?

    Is it possible to break that part of the motherboard? Anyway to fix this or am I sol and need to get another gigabyte mb? Anyway to check?

    My built computer for some reason cannot connect online. I'll post as much info as possible.

    Motherboard: Gigabyte EP45-UD3P
    OS: Windows 7 64bit

    Tried the wizard and trouble shooting and still wont fix the problem. I've got:

    The diagnostics policy service is not running.
    Code 31

    I checked the hardware and driver for possible fix. Got error:

    Microsoft Teredo Tunneling Adapter
    Realtek PCle GBE Family Controller
    Realtek PCle GBE Family Controller #2
    WAN Miniport IKEv2
    WAN Miniport IP
    WAN Miniport IPv6
    WAN Miniport L2TP
    WAN Miniport Network Monitor
    WAN Miniport PPPOE
    WAN Miniport PPTP

    I went to the gigabyte website to try and install possible new drivers and didnt work.

    Is my motherboard the problem? Is the hardware fried? Could uninstalling the driver fix this? Help lol.

  2. #2
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: Having trouble connecting online Error Code 31

    do you have two internet ports on the back? are they both not working? try fully un-installing the drivers and re-install,

    try these latest ones

    http://www.station-drivers.com/telec...ivers.com).exe win7

    http://www.station-drivers.com/telec...ivers.com).exe xp

    http://www.station-drivers.com/telec...ivers.com).exe vista

    remember to run as admin before installing them
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Join Date
    Nov 2010
    Location
    new jersey
    Posts
    2

    Default Re: Having trouble connecting online Error Code 31

    I've tried both ports and still nothing. I tried uninstalling the drivers..ill post a pic tomorrow as well as trying those links you've provided. Thanks for the reply

  4. #4
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Having trouble connecting online Error Code 31

    Your code 31 and comment diagnostics policy service is disable, means you need to enable this in services.

    So open services and enable the diagnostic policy and then run it again and see if it can find the cause of the problem.

    Also in the device manager what is showing for network? And in the BIOS, on the MAIN page, press F9 - do you see a MAC address for each LAN?

    And while you are in the BIOS be sure each LAN is enabled, and you can run the BIOS LAN cable test as well and see if that shows any problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •