Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Gigabyte P55 board and SATA III drive?




  1. #1
    Join Date
    Jun 2011
    Location
    Brandon, Manitoba, Canada
    Posts
    2

    Post Gigabyte P55 board and SATA III drive?

    Just took delivery of a new Barracuda XT 3TB SATA 6Gb/s drive, to solve my storage woes under Linux while slightly increasing my speeds over my older SATA II drives....

    My board (Gigabyte P55A-UD3P) has two SATA III connectors controlled by a Marvell 9128 controller. When the new XT 3TB is plugged in to either of these, system powers up, powers down briefly (2-3 seconds), powers up, and BIOS detects the new drive as an IDE device! This even despite all SATA devices being enabled in ACHI mode in the BIOS.

    However, when plugged into any of the SATA II ports, the drive is properly recognized by the BIOS as one of the SATA devices (along with the optical drive). The system powers up and stays up, instead of powering itself down and up again.

    No other BIOS settings will make it work as a SATA III device, at least to the BIOS.

    1) What is the reason for the strange double-boot behaviour,
    2) Does anyone know why the drive is not recognized as a SATA III device when on a SATA III port?

    I realize that just getting the drive to work with the SATA III ports is probably not going to make my transfers any faster, but I'd like the new drive to use this interface nonetheless, since it is one of the main features of my GIGABYTE board.

    Help?

    My hardware:
    Gigabyte P55A-UD3P, BIOS most recent (F14)
    Core i7 860
    16 GB RAM (Corsair GT 2000 MHz)
    Optical DVD RW SATA interface
    Single ATI HD 4670 Radeon card, on the x16 PCIE bus.
    Corsair HX650 PSU

    Thank you in advance for any and all suggestions!

  2. #2
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: Gigabyte P55 board and SATA III drive?

    Onboard SATA/IDE Ctrl Mode AHCI?

  3. #3
    Join Date
    Jun 2011
    Location
    Brandon, Manitoba, Canada
    Posts
    2

    Default Re: Gigabyte P55 board and SATA III drive?

    Yes, the BIOS section "Integrated Peripherals" contains the settings for IDE mode versus SATA mode versus RAID. I don't run RAID, so all SATA devices (SATA, ESATA, GSATA) are set to AHCI mode in there. Yet the new drive appears as IDE when plugged into the SATA III ports on the m-board, but appears as SATA when in the SATA II port.

  4. #4
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: Gigabyte P55 board and SATA III drive?

    There are two different settings, PCH SATA Control Mode, and Onboard SATA/IDE Ctrl Mode, are both set to AHCI?

  5. #5
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: Gigabyte P55 board and SATA III drive?

    Did you set ahci before installing windows to begin with? If not it won't boot up,maybe its setting default IDE hence the double boot

    To enable ahci after win7 installation follow this reg tweak guide

    GUIDE - Enabling AHCI mode AFTER Windows 7 Installation - Guru3D.com Forums

    Edit just saw your running Linux,I don't know whether ahci had to be set before installing Linux,it does for win7 though
    Last edited by wazza300; 06-28-2011 at 06:44 PM.
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •