Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: VT-D on GA-X58A-UD7 - beta bios?




  1. #1
    Join Date
    Aug 2011
    Location
    Kailua, HI
    Posts
    4

    Default VT-D on GA-X58A-UD7 - beta bios?

    I'm trying to use my GA-X58A-UD7 (rev 01) with VMWare ESXi, but the passthrough feature requires VT-d support from the chipset, CPU, and BIOS. My CPU and chipset both support VT-d, but the BIOS apparently does not. I turned on the option for "Virtualization Support" but I suspect that that is only VT-x, not VT-d. My board originally had the F6 bios, so I tried flashing it to the latest stable bios (F7), but that didn't help.

    so...

    Do either of the beta BIOSes for this board support VT-d? I don't really want to risk flashing my BIOS with a beta BIOS unless I know that it could support this feature I'm looking for.

    There are 2 beta BIOSes out but not much information about what they actually do:

  2. #2
    Join Date
    Aug 2011
    Location
    Germany
    Posts
    1

    Post Re: VT-D on GA-X58A-UD7 - beta bios?

    Same thing here on EX38-DS4. Latest stable, F6c AHCI Beta and F6d Beta Rom haven't brought me VT-d support yet, though my chipset and cpu support VT-d. Would it be possible for Gigabyte (staff) to release an unsupported beta or patch enabling VT-d support? Thank you in advance!


    ---Edit:

    I did some research on this topic (Should apply for most GA Intel-based boards):
    As VT-d is actually a chipset and not a cpu feature, studying the Intel X38 documentation brought up the following reference:


    Code:
    94 Datasheet
    
    5.1.38 CAPID0—Capability Identifier
    
    B/D/F/Type: 0/0/0/PCI
    Address Offset: E0–EBh
    Default Value: 0000000181064000010C0009h
    Access: RO
    Size: 96 bits
    BIOS Optimal Default 0h
    
    This register provides control of bits in this register are only required for customer
    visible component differentiation.
    
    ...
    
    Bit Access Default Value Description
    48 RO 0b VT-d Disable (VTDD): 0 = Enable VT-d 1 = Disable VT-d
    (This is, btw, the only occurance of the term "VT-D" in the chipset specs. So i strongly assume that this is the questionable setting)

    Altough the recommended Default Value is 0b, thus enabling VT-d. The Gigabyte Bios however sets this Bit to 1 (confirmed with WPCREDIT, Device 0, Function 0, Offset 48), thus disabling VT-d and provides no option in bios setup to change this default.

    But why is Gigabyte as OEM knowingly disabling available VT-d support?
    Last edited by puckido; 08-05-2011 at 02:04 PM.

  3. #3
    Join Date
    Aug 2011
    Location
    Kailua, HI
    Posts
    4

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    OK, I wrote to Gigabyte Technical support earlier this week asking them for a VT-d BIOS for the GA-X58-UD7 rev 01 motherboard, and today they DELIVERED!

    I haven't had the chance to test it yet, but here it is in case someone else needs it.

    EDIT: I tried it and it works great.

    Since I posted the BIOS, the old links died (RIP megaupload), so here is an updated link: https://dl.dropbox.com/u/379898/x58aud7.rar
    Last edited by kevin1025; 02-10-2013 at 02:52 AM.

  4. #4
    Join Date
    Aug 2011
    Location
    atlanta, ga, usa
    Posts
    34

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Quote Originally Posted by kevin1025 View Post
    OK, I wrote to Gigabyte Technical support earlier this week asking them for a VT-d BIOS for the GA-X58-UD7 rev 01 motherboard, and today they DELIVERED!

    Here it is:
    MEGAUPLOAD - The leading online storage and file delivery service

    alternate mirror:
    x58aud7.rar

    I haven't had the chance to test it yet, but here it is in case someone else needs it.
    Have you tested? Is VT-d working for you? I have a EX58-Extreme I'm trying to get VT-d working on and I guess I'm going to have to ask for a custom beta bios as well

  5. #5
    Join Date
    Aug 2011
    Location
    Kailua, HI
    Posts
    4

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Quote Originally Posted by chinesestunna View Post
    Have you tested? Is VT-d working for you? I have a EX58-Extreme I'm trying to get VT-d working on and I guess I'm going to have to ask for a custom beta bios as well
    Sorry, realized I never replied. Yes, VT-D worked fine. I didn't use it a lot since I moved on to another project. I don't even have the motherboard anymore but the BIOS link should still be working.

  6. #6
    Join Date
    Aug 2011
    Location
    atlanta, ga, usa
    Posts
    34

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Quote Originally Posted by kevin1025 View Post
    Sorry, realized I never replied. Yes, VT-D worked fine. I didn't use it a lot since I moved on to another project. I don't even have the motherboard anymore but the BIOS link should still be working.
    Lol, blast from the past! I actually went same route and actually got a custom build Bios from Gigabyte support (kudos to them) that got VT-d working.I'm actually still running that board and chip combo in my esxi server and has posted my custom bios which also works for UD5 in another thread.

  7. #7
    Join Date
    Jan 2015
    Location
    United States
    Posts
    1

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Hi guys, since this thread has already risen from the grave I could use some assistance.

    I downloaded the bios you posted above (I've got the same board, x58a-ud7, with an i7 930 in it). Was previously running bios F6. Installed ESXi 5.5u2, noticed VT-d not enabled, and googling brought me here. I flashed your bios this morning, and ESXi doesn't seem to care, I still can't select any PCI devices to pass though. Checked through the bios options near where the "Virtualization Support" setting was (and it was enabled, and I'm pretty sure that was VT-x anyway) can't seem to find anything else.

    What am I missing? I get mixed responses from the interwebs about this CPU supporting it, Some say yes and some say no. Have I missed something?

    Thanks in advance, and again for progress already made.

  8. #8
    Join Date
    Mar 2015
    Location
    Manassas, VA
    Posts
    1

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Like the previous commenter, I feel less guilty posting since this has already been resurrected...

    I seem to be unable to utilize VT-d with the above bios either. Also like the previous commenter, cannot find where to enable it, and my ESXi (5.5) client tells me that the host does not support passthrough configuration.

    X58a-UD7 i7-975x, beta bios posted above.

    If anyone has any tips, or screenshots of where you enable the VT-d, I'd be eternally grateful.

    Cheers.

  9. #9
    Join Date
    Aug 2011
    Location
    Kailua, HI
    Posts
    4

    Default Re: VT-D on GA-X58A-UD7 - beta bios?

    Wish I could be more help but I don't even have the motherboard or CPU anymore. As I recall, after flashing the BIOS, I just went in and saw the setting available (it might have even been on).

    My CPU (I dug through some old receipts!) was: Intel Core i7 Processor i7-920

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •