Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: SATA III SSD shows as IDE channel 2 slave - How can I change this?




  1. #1

    Default SATA III SSD shows as IDE channel 2 slave - How can I change this?

    Hi all, new to the TT forums . . .

    I just rebuilt my PC and installed a new SSD (full system outlined below my sig).

    BIOS "sees" it properly (Patriot Wildfire 120GB SSD), but it's listed as an IDE Channel 2 Slave drive. I believe it should be a Channel 0 Master drive (?), and certainly as a SATA (III) drive. (I have AHCI enabled).

    Nothing I have Googled has helped, and the mobo manual says nothing about the relationship of which physical SATA port equates to which channel or master/slave status.

    How can I change this?

    Thanks in advance,
    Dave G.


    New System basics:

    PC case: Antec 900
    Mobo: Gigabyte GA-FX990-UD5 w/onboard sound
    PSU: ThermalTake ToughPower 750W
    CPU: AMD Phenom II 1090T 6-core
    RAM: Patriot Viper Extreme 8GB DDR3-1866 kit (2x4GB)
    SSD: Patriot Wildfire PW120GS25SSDR 120GB SATA 6.0Gb/s 2.5"
    HDD: 2x Western Digital Caviar Black WD6401AALS 640GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5"
    External HDD: SeagateŽ FreeAgent GoFlex 3TB External Hard Drive
    DVD-R/W: Sony Optiarc AD-7261S-0B Black SATA 24X Dual/Double Layer DVD Burner with LightScribe
    Video: Sapphire AMD Radeon HD 6770 1024MB GDDR5 PCIe 2.0 x16 (I'm not quite a 'hardcore' gamer :-) )
    O/S: Windows 7 Professional (OEM full version)

  2. #2
    Acebmxer's Avatar
    Acebmxer is offline Gigabyte Elite
    Join Date
    May 2009
    Location
    New Jersey, United States
    Posts
    2,817

    Default Re: SATA III SSD shows as IDE channel 2 slave - How can I change this?

    As long as you know you have the ssd drive that you want to install windows; installed on port 0 of the sata3 controller then you should be fine.
    Main Rig
    Gigabyte z87x-OC
    Haswell i7 4770k - 4.7Ghz @ 1.330v LLC Extreme (L310B492)
    G.Skill F3-1700CL9D-8GBXM DDR3-2133mhz 9-11-10-28 1.65v @ 2800mhz 12-14-14-35 1.7v
    Samsung Green 8GB 2x4GB MV-3V4G3D/US DDR3 1.3v 30nn @ 2200Mhz 11-11-11-32 1.60v
    Sapphire ATI HD 7970 3GB clocked 1200MHz @ 1.181v.
    HiS ATI HD 6950
    Samsung 840 Pro 256GB SSD (boot Drive) on Intel sata3 controller port0
    Corsair Force GT 120 GB Sata3 SSD on Intel sata3 controller port1
    Samsung 320GB HD322GJ 7200 RPM 16M cache on Intel sata3 controller port2
    Sony Optiarc DVD-RW AD-7240S on Intel sata3 controller port5
    CORSAIR CMPSU-850TX PSU
    Swiftech MCP655-B Pump
    EK Supremacy Cpu Block
    Swiftech Mcres Micro Rev 2 Reservoir
    Black Ice GTX Xtreme 360 Radiator





  3. #3
    Join Date
    Oct 2010
    Location
    England
    Posts
    56

    Default Re: SATA III SSD shows as IDE channel 2 slave - How can I change this?

    Hi there,

    for some reason I have never been able to understand, Gigabyte have left the SATA ports identification in BIOS as IDE channels. This is confusing, nothing to worry about and there is nothing you can do to change it.

  4. #4
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: SATA III SSD shows as IDE channel 2 slave - How can I change this?

    Which port the SSD is connected(of the chipset ports) or if it's a slave or a master should make no difference.

    At least on my board, when AHCI is enabled there are no IDE devices detected.

    If the SSD is connected to port 4 or 5 you need to set OnChip SATA Port4/5 Type to As SATA Type.
    If you have it connected to a GSATA3 port (grey) you need to set GSATA3 Ctrl Mode to AHCI or move it to one of the chipset ports (black) which is the better choice.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •