Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: What did I mess up with my Marvell 9128 driver??




  1. #11
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: What did I mess up with my Marvell 9128 driver??

    Disabling SLI might not be a good enough test, you might have to physically remove the second video card for testing.
    My best guess is that removing the second video probably won't help because only the Gsata3 ports support sata3 6GB/s speeds. The remaining sata ports are all sata2 and these are handled by the Intel chipset.

    Let me know if I'm wrong ;)
    Your board has six sata2 ports and two Gsata3 ports.

    What did I mess up with my Marvell 9128 driver??-p55_chipset_block_diagram-png
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  2. #12
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: What did I mess up with my Marvell 9128 driver??

    i wonder if you added in a pci sata3 card that you would get full sata3 speeds? cant see how it would slow things if it wasnt handled by the intel chipset?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #13
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: What did I mess up with my Marvell 9128 driver??

    The cpu handles the PCI-e lanes for the video card, with 16 lanes maximum for video.
    The P55 chipset handles all PCI-e and PCI slots.

    From P55A-UD4P motherboard user manual:

    What did I mess up with my Marvell 9128 driver??-p55a-udp4-motherboard-block-diagram-png
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  4. #14
    Join Date
    Feb 2010
    Location
    Springfield, MO
    Posts
    17

    Default Re: What did I mess up with my Marvell 9128 driver??

    I don't understand the implications of the diagram very well - but would that lead me to think it would be best to disable usb 3.0 and the extra LAN port if not in use to relieve pressure on that pci-e lane? I tried disabling SLI and like you said, there was no effect. Frustrating since I did have double the speed at some point. It literally went from 246/411 to 131/208. Maybe I'll yank that card out and see if that does the trick.

    --

    Well... bugger... that didn't do anything (pulling the SLI'd card). Back to the drawing board. Wish I kept track of what driver combination that was. The other thing I did was to install different ram chips -that should affect the results, should it?
    Last edited by Ozark_750; 12-06-2011 at 11:40 AM.

  5. #15
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: What did I mess up with my Marvell 9128 driver??

    It's good practice to disable (in the bios) unused hardware options to free up system resources that aren't needed or being used. Doing this will free up memory and wont load drivers and their programs while your system is running.
    I don't understand the implications of the diagram very well - but would that lead me to think it would be best to disable usb 3.0 and the extra LAN port if not in use to relieve pressure on that pci-e lane?
    "Freeing up" lanes doesn't really make more lanes available for other hardware. In some cases, I've read in the motherboard user manual than enabling or using USB 3.0 will "steal" some lanes from some other hardware resources.

    Definitely remove the second graphics card and repeat your benchmark.
    It might help if you also benchmark your drives using the Intel sata2 ports.
    It helps to keep detailed notes when you're troubleshooting problems.

    Whenever I'm installing or removing hardware inside the computer case, I always:
    1. Turn off the system
    2. Turn off the power supply using the on/off psu switch at the back of the case
    3. Press and hold the main on/off switch for 10 - 15 seconds to discharge capacitors that can still hold a charge
    4. Then I remove or install the hardware
    I even do these steps when installing or removing case cooling fans.
    Why? One time I disconnected a fan wire and the loose end of the fan cable caused a momentary short circuit.
    If you don't follow this procedure there is a good chance that you will damage hardware.

    Please add a detailed hardware list to your forum signature.
    This will cut down on possible errors when we are also working in other threads where they often have similar setups.
    It's a royal PITA to have to scroll through a thread to find out exactly what hardware you have in your system.
    Note the detail in my signature. I have links to my hardware's specifications in the entries that are underlined. Flashy or gaudy colors are optional. If I were into gaming, I would add information about my mouse and keyboard.

    On some occasions when we are diagnosing a system, it's necessary to remove nearly all the hardware to get to a minimal hardware setup and then start adding one piece of hardware at a time, then boot and see if adding one piece of hardware causes any problems.

    edit:
    Changing your system memory MIGHT be part of the problem, can you say ARRRGGGG!!!!
    Last edited by profJim; 12-06-2011 at 12:36 PM.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  6. #16
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: What did I mess up with my Marvell 9128 driver??

    Quote Originally Posted by Ozark_750 View Post
    Well... bugger... that didn't do anything (pulling the SLI'd card). Back to the drawing board. Wish I kept track of what driver combination that was. The other thing I did was to install different ram chips -that should affect the results, should it?
    Note 1 in the board spec webpage
    When dual graphics cards are used in 1st and 2nd PCIex16 slots, SATA3 / USB 3.0 (Marvell 9128 /NEC USB 3.0 Controllers) will work at normal mode.
    This make it very clear that they "steal" bandwidth from the PCIe x 16, something that is not shown in the block diagram.
    The image of the chipset block diagram is misleading as well, even though it says each lane is 500MB/s it is in fact just 250MB/s as you can see in the product brief just below the same image.

  7. #17
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Thumbs down Re: What did I mess up with my Marvell 9128 driver??

    When dual graphics cards are used in 1st and 2nd PCIex16 slots, SATA3 / USB 3.0 (Marvell 9128 /NEC USB 3.0 Controllers) will work at normal mode.
    Nice find Chike.

    What kind of bull dung is this? Normal = crippled mode?
    If you want to run SLI, all you have to do is use the rest of the advanced features with "un-advanced" performance levels!!!

    I've seen this type of dung to some extent with other brands, but not this crippled.
    If this is what I have to look forward to with Ivy Bridge, I'm staying with my P35 system.
    I might edit this post a little after I've cooled down a bit.
    Naw, I'll let it be.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  8. #18
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: What did I mess up with my Marvell 9128 driver??

    By normal i guess it means they go through the PCIe x1 lane.
    Actually the could give up the JMB chip and one LAN port and run the USB3.0 and SATA3 in PCIe x2, which is enough for the USB and "almost" enough for SATA3.

    Well the Sandy Bridge already has 2 SATA3 ports on the chipset so no problem there.

  9. #19
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: What did I mess up with my Marvell 9128 driver??

    Which benchmark test (and version number) have you been using for your ssd tests?
    Did you use default test options or did you manually change any test settings?

    From the OP's added edit in post #14, physically removing the 2nd SLI card didn't help the SSD benchmark score.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  10. #20
    Chike is offline Senior Member
    Join Date
    Jun 2009
    Location
    Israel
    Posts
    6,531

    Default Re: What did I mess up with my Marvell 9128 driver??

    I'd try clearing CMOS while the 2nd card out and load optimized defaults again.
    Which slot is the remaining card in, PCIEX16 or PCIEX8?

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •