maybe im missing something,but with turbo disabled it should stay at whatever multiplier you set?