Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: GA-X79-UD5: Can't get SMART or temp data from any HDD.




  1. #1
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Question GA-X79-UD5: Can't get SMART or temp data from any HDD.

    I've finally got time to install my GA-X79-UD5 that has been lying around for quiet some time but encountered some weird problem with getting SMART data or temperature for my HDDs. Every single tool I've tried in Windows just can't get any data (HDTune, AIDA64...).
    I was suspecting that SMART feature is disabled in BIOS but it's seems like there is no such option in BIOS settings or at least I can't find one. I've even tried to update BIOS to F10 but still no luck.

    Broken MB or am I doing something wrong?

  2. #2
    Join Date
    Nov 2008
    Location
    Florida, USA
    Posts
    90

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Hi,
    I have the same motherboard and I am able to read SMART and temperature data using AIDA64. I have not changed anything related (no settings for SMART as far as I know) in the BIOS from default.
    It is set up for all hard drives to use AHCI, Intel and Marvell.

    I am using F12 BIOS currently but it worked in F8, F10 and F11c.
    I'm not sure what to suggest.
    Gigabyte GA-X79-UD5 v1.0 @ F13s
    Intel Xeon E5-2670
    Intel BXRTS2011LC Liquid-cooled LGA 2011
    64GB (8x8GB) Quad Channel G-Skill Ripjaws Z series DDR3 2133
    EVGA GTX 950 FTW 2GB
    Thermaltake Armor+
    Samsung 850 EVO 250 GB SSD
    1 x 2TB WD 2002FAEX SATA
    4 x 2TB WD 20EFRX SATA
    7 x 3TB WD 30EFRX SATA
    Seasonic X-1050 Power Supply
    ASUS RT-AC68U router
    Windows 7 Ultimate x64 SP1
    Windows 8.1 Pro x64
    Windows 10 Pro x64

  3. #3
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Thanks for reply.

    I've tried switching one of HDDs from Intell to Marvell controller and have exactly same result. HDD works ok but can't get any reads from it Smart or temperature.
    How is it even possible? It seems unlikely that both controllers end up with exact same issue.

    Is there anythig that can interfere with getting SMART and temp data from HDDs? Or is there any way to check that it's actuall MB issue or not?

  4. #4
    Join Date
    Nov 2008
    Location
    Florida, USA
    Posts
    90

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Are your controllers set to AHCI, RAID or IDE?
    Gigabyte GA-X79-UD5 v1.0 @ F13s
    Intel Xeon E5-2670
    Intel BXRTS2011LC Liquid-cooled LGA 2011
    64GB (8x8GB) Quad Channel G-Skill Ripjaws Z series DDR3 2133
    EVGA GTX 950 FTW 2GB
    Thermaltake Armor+
    Samsung 850 EVO 250 GB SSD
    1 x 2TB WD 2002FAEX SATA
    4 x 2TB WD 20EFRX SATA
    7 x 3TB WD 30EFRX SATA
    Seasonic X-1050 Power Supply
    ASUS RT-AC68U router
    Windows 7 Ultimate x64 SP1
    Windows 8.1 Pro x64
    Windows 10 Pro x64

  5. #5
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Both controllers are in AHCI mode.

    And apparently I've found the cause of that bug. It's seems like Intel RST driver is causing that problem.
    Here what I've found on Intel forums and AIDA64 forums.

    Now is the question: If I'll remove Intel RST drivers from my Windows 7 OS will be able work properly or should I live with that bug?

    pbcopter,
    Do you have that Intel Rapid Storage driver installed in your system? And if you do, which version is it?

  6. #6
    Join Date
    Nov 2008
    Location
    Florida, USA
    Posts
    90

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    I'm using the Intel version 11.1.0.1006 driver, not the Enterprise drivers.
    http://www.station-drivers.com/page/intel%20raid.htm

    I'm surprized that the Intel driver effects the Marvell controller though.
    Last edited by pbcopter; 06-04-2012 at 01:39 AM.
    Gigabyte GA-X79-UD5 v1.0 @ F13s
    Intel Xeon E5-2670
    Intel BXRTS2011LC Liquid-cooled LGA 2011
    64GB (8x8GB) Quad Channel G-Skill Ripjaws Z series DDR3 2133
    EVGA GTX 950 FTW 2GB
    Thermaltake Armor+
    Samsung 850 EVO 250 GB SSD
    1 x 2TB WD 2002FAEX SATA
    4 x 2TB WD 20EFRX SATA
    7 x 3TB WD 30EFRX SATA
    Seasonic X-1050 Power Supply
    ASUS RT-AC68U router
    Windows 7 Ultimate x64 SP1
    Windows 8.1 Pro x64
    Windows 10 Pro x64

  7. #7
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Smile Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    It seems like somehow that driver affecting all drives installed in system no matter which contoller they're using. Probably intercept certain interrups on system wide basis.
    Will try to replace Enterprise drivers with non-enterprise ones since it's kinda confusing with this bug.

    And thanks for info, pbcopter.

  8. #8
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Quote Originally Posted by pbcopter View Post
    I'm using the Intel version 11.1.0.1006 driver, not the Enterprise drivers.
    intel drivers pour Raid/Sata/Ata/Ahci
    Hm. I've tried to install RST 11.1.0.1006 but it said that it can't install on my system because it can't find corresponding device :\

  9. #9
    Join Date
    Nov 2008
    Location
    Florida, USA
    Posts
    90

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Yeah, sorry I should have mentioned, you have to either modify the .inf file or choose the "Desktop/Workstation/Server Express Chipset SATA AHCI Controller"
    Gigabyte GA-X79-UD5 v1.0 @ F13s
    Intel Xeon E5-2670
    Intel BXRTS2011LC Liquid-cooled LGA 2011
    64GB (8x8GB) Quad Channel G-Skill Ripjaws Z series DDR3 2133
    EVGA GTX 950 FTW 2GB
    Thermaltake Armor+
    Samsung 850 EVO 250 GB SSD
    1 x 2TB WD 2002FAEX SATA
    4 x 2TB WD 20EFRX SATA
    7 x 3TB WD 30EFRX SATA
    Seasonic X-1050 Power Supply
    ASUS RT-AC68U router
    Windows 7 Ultimate x64 SP1
    Windows 8.1 Pro x64
    Windows 10 Pro x64

  10. #10
    Join Date
    Sep 2009
    Location
    Russia, Moscow
    Posts
    17

    Default Re: GA-X79-UD5: Can't get SMART or temp data from any HDD.

    Have you only added 2 lines to the .inf file:
    Code:
    [INTEL_HDC.ntamd64]
    ...
    %PCI\VEN_8086&DEV_1D02&CC_0106.DeviceDesc% = iaStorA_inst, PCI\VEN_8086&DEV_1D02&CC_0106
    and
    Code:
    [Strings]
    ...
    PCI\VEN_8086&DEV_1D02&CC_0106.DeviceDesc    = "Intel(R) C600 Series Chipset SATA AHCI Controller"
    Will it be enough or should I change something else?

    Quote Originally Posted by pbcopter View Post
    or choose the "Desktop/Workstation/Server Express Chipset SATA AHCI Controller"
    Not sure if I got what do you mean here. Choose where?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •