Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: GA-Z77X-UD5H and Logitech 520 Wireless KB and Mouse




  1. #11
    Ken429 is offline Senior Member
    Join Date
    Aug 2009
    Location
    Valapariso, Indiana
    Posts
    516

    Default Re: GA-Z77X-UD5H and Logitech 520 Wireless KB and Mouse

    Yes, I saw the post by 2therock after I posted on this thread. I'll give F9q a try. Acebmxer, it's good to know that there is at least one Logitech wireless KB and Mouse that works with this MB. As a last resort I'll try one and verify that it works on a UD5H with BIOS version F7. It must be the miniature USB sending unit on the K520 that Gigabyte does not like?!

  2. #12
    2therock's Avatar
    2therock is offline Member
    Join Date
    Mar 2008
    Location
    N. GA US
    Posts
    262

    Default Re: GA-Z77X-UD5H and Logitech 520 Wireless KB and Mouse

    Yes, it works. I have been experimenting across all the USB ports, If I was doing this on my old Chevy 327 the starter would be trashed. Cutting through the Chase, on the Logitech K350, have your USB transmitter as close as you can. You don't have to remodel your desk, just don't get careless.
    The testing or trials I do are the same as always, USB transmitter wired to case ports first, then board ports being 2.0 & 3.0 on all. Then I plug the transmitter directly into all the same ports, then I lean the keyboard next to the transmitter. In all the BIOS files I have tried other than F9q it never let me into BIOS.

    Out of at least two dozen boots F9q has failed only once plugged into a case 2.0 port and this was with the transmitter in the USB cable socket as far away from the keyboard as I could get it.

    To keep the clutter down I now have the receiver cable in the USB 2.0 port over the Intel NIC. It just so happens the receiver is 6" from the board as always.

    One of the things the Gigabyte tech said was to try tapping the delete key instead of holding it down. He noted in some cases holding it down before it gets activated will not let it acknowledge? I always tap from the old days but have tried both.

  3. #13
    Ken429 is offline Senior Member
    Join Date
    Aug 2009
    Location
    Valapariso, Indiana
    Posts
    516

    Default Re: GA-Z77X-UD5H and Logitech 520 Wireless KB and Mouse

    So far so good. I just updated BIOS to F9q and it appears like my Logitech K520 KB and Mouse work in the BIOS and in W7. I have the sending unit plugged into one of the USB 2 ports in the back of the MB. I have not tried moving it around - I just darn happy that it works where it is!! I did have some trouble with the BIOS update - I had to plug the USB thumb drive with F9q in one of the USB 3 ports on the back of the MB in order for the BIOS (F7) to recognize it for flashing. Also, I had the "usual" BIOS issue of not recognizing the SSD boot drive the second time I did a cold reboot. I'm not sure what cause this but I had a similar issue with an ASUS MB. It's almost like the BIOS gets wrapped up doing it's thing with all the changes and misses the SSD.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •