Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: GIGABYTE GA-Z77-DS3H Problem with new PCi Express card

  1. #1
    Join Date
    Mar 2009

    Default GIGABYTE GA-Z77-DS3H Problem with new PCi Express card

    Hi all
    OK I have a Gigabyte GA-Z77-DS3H motherboard with an Intel i5-3470 Quad-Core at 3.4GHz,
    Sapphire HD 7850
    But the monitor dosen't display anything when I connect it to my new card (Sapphire HD 7850)
    But the monitor comes on when I use the on-board graphcis from the Gigabyte GA-Z77-DS3H. I have also tried changing the graphics card completley for a different card and that's the same problem.

    Any suggestions

  2. #2
    Join Date
    Aug 2009
    Birmingham,Great Britain

    Default Re: GIGABYTE GA-Z77-DS3H Problem with new PCi Express card

    tried setting display as peg or the graphic card in the bios? and disable the onboard igpu?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/[email protected] 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!! Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Join Date
    Nov 2012
    Poland, Toruń

    Default Re: GIGABYTE GA-Z77-DS3H Problem with new PCi Express card

    I know what is the problem its the SAPPHIRE card.
    I've just posted a thread with the exact same problem:

    I can assure you 100% that if you set in your bios pci gen to 2 or 1 your card will work ( first tab on the left, go to miscellaneous)

    I've researched the problem and found out it usually involves the 7850 model card from sapphire and affects gigabyte, asus and some asrock motherboards.

    I'm in the middle of rma'ing my card but i'm afraid that they (sapphire) will always have some test motherboard that this card actually works in 3.0 mode and thus will reject any claims of malfunction :/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts