Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: I installed Win7 Pro 64 bit in my SSD on IDE mode




  1. #1
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default I installed Win7 Pro 64 bit in my SSD on IDE mode

    Serial ATA AHCI BIOS, Version iSrc 1.07 08042006
    Copyright (c) 2003-2006 Intel Corporation
    ** This version supports only Hard Disk and CDROM drives **
    Please wait. This will take few seconds.

    I did changed ACHI mode before trying to install win7 but I didn't saved the changes in Bios, so I installed them in IDE mode.

    After installation was done I changed to ACHI mode from bios and the above message is appearing, after 10 seconds the bios says that ACHI bios installed and then proceeds to the welcome screen and enters desktop.
    And the second issue is that my SSD and 2 HDD show on the bottom right as removable devices.

    After doing my search I couldn't find a solution.

    I switched back to IDE from BIOS the message was removed and my drives weren't showing as removable devices. Yes it appears that I fixed the glitches but after doing this my SSD performance from 252mb/s dropped to 175mb/s

    Update: I can't install Intel Rapid Rapid Storage Technology, or at least i have issues doing so. It says that my system doesn't meet the minimum requirements.
    I don't run on RAID mode.


    Hope you can help me

    Thank you

    Panayiotis
    Last edited by Yiotis_82; 01-01-2013 at 02:06 AM.

  2. #2
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    boot up in ide mode,download/run this reg tweak file,reboot into bios and set to ahci,save exit and boot up into windows,it should work then

    http://cdn.ithinkdiff.com/wp-content...09/05/ahci.reg
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    I did what you told me but nothing changed. Drives still show as removable and the message before welcome screen still appears.

    what did the tweak file done?

    I installed Win7 Pro 64 bit in my SSD on IDE mode-drives-jpg
    Last edited by Yiotis_82; 01-02-2013 at 08:27 PM.

  4. #4
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    it just enables ahci drivers without having to reinstall

    they shouldnt be showing up as removable devices idk why thats happening

    your setting to ahci in the bios and not raid/ahci?

    if you are you could try raid ahci and see if that gets rid of the removable devices
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  5. #5
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    In the bios i just enable ACHI for peripherals

    I haven't noticed if their is raid option elsewhere.

    I will try later

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    This board has the ICH9 SATA chipset, no RAID capability.

    The message you see at boot is simply the AHCI driver loading, nothing wrong with that. That is the Windows 7 AHCI driver, msahci, loading. I assume the older board/BIOS may show that on every boot, if so no problem.

    You can't load the Intel IRST driver in IDE mode, which is why you see the hardware error message, again normal. BTW, after you change to AHCI mode and get an AHCI driver loaded, a CMOS clear is a good idea, and of course then setting your BIOS settings to what they need to be, including AHCI.

    The thing with the removable drives is likely due to an older boards BIOS and the AHCI driver not being quite on the "same page", as they say. Two things to check to fix that.

    To get rid of the removable drive thing, go into Device Manager, and open Disk drives. For each drive, click the Policies tab. You should see options for Quick Removal, Best Performance, etc. Quick Removal is likely checked, uncheck that and set Best Performance, and click Ok. You may need to restart to reset those options.

    Since AHCI enables "Hot Plugging", that may be enabled in your BIOS, if that option is available. Check any drive listing in the BIOS, and disable Hot Plugging if it is there. If no setting for that, AHCI is simply defaulting to Hot Plugging enabled, which is why you see the drives as removable. That is not really a big problem, but hopefully you can turn that off in Device Manager.

  7. #7
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    1) Then I wont try for raid function.

    2) Yes i know, it's just my cousin built a new pc after asking me what to buy. We have the same SSD and operating system but newer gigabyte motherboard. his pc starts way faster. mine is slower due to my delay while trying to load the ACHI driver. And that got my attention.

    3) best performance was checked from the start, never had to change that. for all 3 drives

    4) I will check for hot plugging.

    IF I don't find a solution I will probably get rid of it when I get myself a new motherboard that fully supports SSD.

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    IMO, the loading of the AHCI driver on every boot is strange, I get the feeling that the registry change that allows changing from IDE to AHCI mode was not done completely right. Or changing back to IDE as you did at some point (I think) changed a registry setting, which is causing the AHCI driver to load, when it is not necessary.

    I would check the registry settings that were changed for AHCI mode for the correct values. Also it is possible there are multiple entries in the registry for the drivers, and Windows is using a different one that is not set quite right. Don't forget that the changes of the registry settings that allow the AHCI driver to load should be at the usual, non-load setting after the driver is loaded, not what they must be for the one time change to occur. Be careful and do some research before changing anything.

    All board are different, and some POST slower than others. I'm not including that driver load here. It also depends on how many HDDs the PC has, extra cards (sound, etc) and what the manufacture included as features for the board. My ASUS X58 board has extra diagnostic checks added by ASUS, and the POST takes forever...

  9. #9
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    After installation of win7 was done I changed to ACHI mode from bios. When I was doing my research all changes that I had to do to the registry were already their. I couldn't do more.

    I' m comparing load times of the boards which are the same brand.

    Thing is, if I had installed win7 with ACHI mode would I have this issue?

    I found on another forum that I could make a backup image, change to ide, format, change to achi and install again from image.
    It warns that if i have more than 1 drive connected at that point those that don't have the image will get formatted automatically. And it does warns also that I could have issues backing from the image. Windows bugs.

    so I will need to find more about correcting the registry but I will still wonder if it's not fixed, if I wouldn't have this issues if I had install in ACHI in the first place.

  10. #10
    Yiotis_82 is offline Junior Member
    Join Date
    Dec 2012
    Location
    Cyprus
    Posts
    13

    Default Re: I installed Win7 Pro 64 bit in my SSD on IDE mode

    I changed to native mode and the only thing that changed is the page file place in the SSD. It moved to the middle of the drive. You think it will cause anything to my drives this mode?

    To enable hot plug capability for the SATA connectors (SATAII0, SATAII1, SATAII4, SATAII5)
    controlled by the ICH9 South Bridge, you must install Windows Vista (on ICH9, hot plug is
    supported in Windows Vista only) and configure the SATA connectors for AHCI mode. (Refer
    to Chapter 2, "BIOS Setup," "Integrated Peripherals," for details on enabling AHCI.)

    This is in the manual of my mother board, seems that I can't do anything else.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •