Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Sapphire 7970 OC not detected on GA-Z77X-UD5H-WB ?????




  1. #1
    perrysu is offline Junior Member
    Join Date
    Mar 2013
    Location
    Chicago
    Posts
    2

    Question Sapphire 7970 OC not recognized on GA-Z77X-UD5H-WB ?????

    UPDATE 3/24:
    It turned out that the Mobo's PCI-E X16 is FAULTY while PCI-E X8 works like a charm.

    Hi guys, first time here with frustration and doubt. I ran into a huge problem doing a build in 9 years:
    The mobo just WON'T recognize my Sapphire 7970 plugged into PCI-E x16. Below is what I find about the issue.
    1). the video card is connected with 2x 8pin connectors from the PSU with 2 fans doing just fine;
    2). yet UNABLE to find it in the device manager, on-board Intel HD 4000 works well though
    3). updated BIOS to the lastest beta F15q via QFlash, expecting miracles
    4). tried to disable on-board graphics in BIOS, then use card's DVI port but it gives 'no signal'
    5). BIOS DOESN'T seem to save the change in 4). On-board graphics is always 'auto' every time I see it.
    6). 'Mainboard' panel of CPU-Z shows that 'Graphic Interface' section comes BLANK without info about PCI-E slots. It's like that when no video card detected?
    7). will try plug it into x8 or x4 slot to see it works out tomorrow. A bit hard to test the card on another build btw.

    Need help on this for sure. Thx in advance.
    Is it the card itself?
    Could it be the BIOS or the slot?
    I really don't wanna go RMA.....
    Last edited by perrysu; 03-25-2013 at 04:06 AM. Reason: Issue updated

  2. #2
    Rale is offline Junior Member
    Join Date
    Dec 2012
    Location
    UA
    Posts
    83

    Default Re: Sapphire 7970 OC not detected on GA-Z77X-UD5H-WB ?????

    Your Sapphire 7970 OC is dualbios.
    Try to switch to another one.

    If not help:
    - clear motherboard cmos (by button and battery removing) also unplug power cable from psu. (in both cases motherboard should be turned off)
    - and
    Quote Originally Posted by perrysu View Post
    will try plug it into x8 or x4 slot to see it works out tomorrow. A bit hard to test the card on another build btw.
    Also there could be a problem with the PSU and the video card is not turned on.
    You can try to connect to the molex to 8 pin adapter.
    Quote Originally Posted by System Requirements
    2X75 Watt 6-pin PCI Express power connector is required for CrossFireX™ system.
    1X75 Watt 6-pin PCI Express power connector is required.

    Certified power supplies are recommended. Please refer to: AMD Certified Power Supplies
    500 Watt Power Supply is required.
    1X150 Watt 8-pin PCI Express power connector is required.
    2X150 Watt 8-pin PCI Express power connector is required for CrossFireX™ system.
    Sorry for my English, its not my native language.

  3. #3
    perrysu is offline Junior Member
    Join Date
    Mar 2013
    Location
    Chicago
    Posts
    2

    Default Re: Sapphire 7970 OC not detected on GA-Z77X-UD5H-WB ?????

    Quote Originally Posted by Rale View Post
    Your Sapphire 7970 OC is dualbios.
    Try to switch to another one.

    If not help:
    - clear motherboard cmos (by button and battery removing) also unplug power cable from psu. (in both cases motherboard should be turned off)
    - and

    Also there could be a problem with the PSU and the video card is not turned on.
    You can try to connect to the molex to 8 pin adapter.
    Thx for the suggestion. Problem half solved for now.
    It turned out that the Mobo's PCI-E X16 is FAULTY while PCI-E X8 works like a charm.
    I should have made up my mind going RMA by next week.
    Last edited by perrysu; 03-25-2013 at 04:06 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •