Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Titan




  1. #1
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Titan

    hi all I have bought a titan but I cannot get it to register on he mobo it is a GA-Z68MA-D2H-B3 v1 ive tried all slots I do know the titan works in another machine as the mate who bought it for me tested it. my bios is F8

  2. #2
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Titan

    Did you connect both pci-e cables to your Titan video card? Your Titan probably requires one 8-pin and one 6-pin psu pci-e cable .
    What is the brand and model number of your power supply?

    We need detailed information about ALL OF THE HARDWARE in your system.

    We can best help you after you create a detailed hardware list in the System Specs portion of your
    forum profile http://forums.tweaktown.com/profile.php?do=editprofile at the bottom of the
    profile page or in your forum signature http://forums.tweaktown.com/profile....=editsignature.
    Be sure to include brand names and model numbers.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  3. #3
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Re: Titan

    hey mate ya I have the 8pin & 6pin both connected the PSU is an

    700 Watt OCZ ModXstream PRO Power Supply (OCZ700MXSP)
    i5 2500k with coolermaster 412
    corsair vengeance 8gb (2x4)
    OCZ vertex4 SSD 256 (OS)
    OCZ Petrol SSD 256 (games)
    4 case fans (CM Stormtrooper case)

    I was running SLI 670s ages ago then gave one away and have been running a single 670 up till now

  4. #4
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Titan

    Can you borrow and test with another power supply?
    How old is your power supply?
    Does the Titan's fan spin?
    Does your video card have a bios switch that lets you choose between two different video bios settings.
    You might need to contact tech support for the manufacturer of your video card.
    Problems like yours sometimes need a motherboard bios update to fix the problem.

    It's a PITA for us when we can't quickly see a complete hardware list.
    Right now we don't know the brand of the Titan, your O/S versio, bios version, memory model number etc.
    Many of us are helping in many threads at the same time.

    It takes very little time to list your hardware using the form in the System Specs portion of your profile.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  5. #5
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Re: Titan

    hey profJim ive tried 4 times times to save the system specs but it aint/I cant get it working for some reason

  6. #6
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Titan

    OK, I'll check it out.
    Not being able to save the settings (at the bottom of the page) has happened before.
    I'll see if I can change and save the settings in my PC Specs.

  7. #7
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Re: Titan

    Quote Originally Posted by profJim View Post
    Can you borrow and test with another power supply?
    How old is your power supply?
    Does the Titan's fan spin?
    Does your video card have a bios switch that lets you choose between two different video bios settings.
    You might need to contact tech support for the manufacturer of your video card.
    Problems like yours sometimes need a motherboard bios update to fix the problem.

    It's a PITA for us when we can't quickly see a complete hardware list.
    Right now we don't know the brand of the Titan, your O/S versio, bios version, memory model number etc.
    Many of us are helping in many threads at the same time.

    It takes very little time to list your hardware using the form in the System Specs portion of your profile.
    But for the life of me I cannot get System Specs to save

    its an EVGA TITAN EVGA | Products | EVGA GeForce GTX TITAN | 06G-P4-2790-KR
    OS is x64 Windows 7
    Bios is F8 GIGABYTE - Motherboard - Socket 1155 - GA-Z68MA-D2H-B3 (rev. 1.0)
    DDR3 8GB (2x4G) Corsair 1600MHz Vengeance CL9 Kit

  8. #8
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Titan

    PC Specs is broken and won't save any changes.
    I've reported it but it might take several days for it to be fixed.

    You can create a hardware list in your forum signature and the list will be displayed in each of your posts after you've saved it in the forum signature page.

  9. #9
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Re: Titan

    apologies the fan does spin & I have both the 6pin & 8pin PCI plugged in

    ok mate

  10. #10
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    7

    Default Re: Titan

    well I put it all in signature so hope it works
    GA-Z68MA-D2H-B3 v1
    i5 2500k CPU @4.4
    coolermaster Hyper 412
    EVGA GeForce GTX TITAN P/N: 06G-P4-2790-KR
    Corsair Vengeance CMZ8GX3M2A1600C9 8GB (2x4GB) DDR3 1600MHz 9-9-9-24
    CM Storm Trooper Case
    OCZ Vertex 4 256gb (W7OS x64)
    OCZ Petrol 256gb (Games)
    700 Watt OCZ ModXstream PRO Power Supply (PN OCZ700MXSP)
    3x BENQ 24" 1080p

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •