Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]




  1. #1
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    *Fix issued* (See link at the bottom of this post)

    Hi all,

    If you have this problem
    Yeah...M$ did it again

    I am pretty sure that you installed your Win 8.1 in UEFI mode thinking that ...yeah 8.1 must be better that 8 which for the record it isn't yet for many user (ex. some drivers are not ready for 8.1 and so on) and UEFI is the new thing so I want it. And I want even more "Utra Fast Boot" that UEFI installation is suppose to provide

    I bet you enabled "Secure Boot" and installed secure boot keys to get rid of the damn water mark "secure boot isn't configured correctly" in Win 8.1 at the right bottom of the desktop.

    You probably followed the instruction on many other web site to try to get ride of that i.e. installing the default Secure Boot keys then enable Secure Boot.

    Now you don't have water mark anymore but you are not able to go to the BIOS no matter what.


    This is because you have a discrete video card that doesn't have a GOP (Graphics Output Protocol) vbios.
    Your graphic card is not UEFI compatible

    (N.B. Gigabyte do not warn user of that possibility. Other manufacturers do warn user that the graphic card is not compatible with Secure boot. But nonetheless Gigabyte board are great boards)

    If you are able to see something after the boot sequence you are lucky in a sense that at lease the video card starts (it doesn't for many ppl)

    I haven't seen a solution to fix that yet other than:
    - use the internal Intel IGFX . Enabling it (not "Auto" but "Enable") in the bios and you monitor connected to it)
    - or ask your graphic card manufacturer to provide you a GOP vBIOS (if you are lucky enough)
    - or to buy a compatible graphic card (only a few one can at the moment).
    (- if you search hard on internet there is a tweak to remove the watermark but it involve editing (messing) with 2 or 3 files)

    If you don't need to go in the BIOS often...then stand still and live with it for now. " If it's not broke, don't fix it" like they say.
    If you don't need Win in UEFI and you are doing a fresh installation ....do it in legacy mode. (or not)

    Of course you can always reset your BIOS and I mean really reset it (I had to reflash it, reset was not enough to get rid of the keys), in accordance to the instruction for your motherboard
    *Warning ...Be Cautious* Bricking a motherboard is not fun at all.

    If you have dual BIOS ...boot on the second one...copy it to the main BIOS and reflash the main BIOS with the latest version, that will clear the keys, and do not enable secure boot again unless you and applied the solution above or wait for M$ next move.

    There is rumors that M$ will issue a patch for assessing the watermark thing.
    But it is just rumors

    Hope it helps

    Update: For those who have Windows 8.1 setup in Legacy mode (with a MBR) ...just clear the keys, disable "Secure Boot" and Enable "UEFI Compatibility Support Module " (aka CSM support) and disable all UEFI related option. All Oproms at "Legacy Only". The watermark should go away.
    Update 2: Intel as release a fix for Intel motherboard (only).

    Update 3: M$ (Microsoft) has releases a hotfix to fix the issue (KB 2902864) (please report if it doesn't work for your configuration, Many Thanks)

    Update removes the "Windows 8.1 SecureBoot isn't configured correctly" watermark in Windows 8.1 and Windows Server 2012 R2

    Regards
    Last edited by Teddybehr; 10-30-2013 at 03:39 PM. Reason: Fix issued

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Yes, I have that watermark on my Windows 8.1 screen, and I had Windows 8 installed in UEFI booting mode. That remained after the 8.1 update.

    I have not enabled Secure Boot, since that is not necessary to enable the Windows 8 Ultra Fast boot mode. I don't use a Gigabyte board, but their UEFI/BIOS may have the same option, CSM. Disabling CSM enables UEFI booting, and is independent of using Secure Boot. OTOH, enabling Secure Boot will automatically disable CSM. That is how some guides tell you to enable UEFI booting, and it works. But you do not need to use Secure Boot to have a UEFI booting PC. That is, as long as your board's UEFI/BIOS has the CSM option available.

    The issue with not being able to get into the UEFI/BIOS with Secure Boot is really just the side affect of Ultra Fast Boot (UFB) being enabled by enabling Secure Boot. UFB either bypasses the ability to enter the UEFI/BIOS by pressing Del, etc, or it's just to fast for us to press the key in time. Again, Ultra Fast Boot is independent of Secure Boot, if your board's UEFI has the right options available. Windows 8 has an option to restart a PC directly into the UEFI/BIOS when UFB is active.

    My ASRock boards have Secure Boot, CSM, and Fast Boot (mode) as separate options. So I can toggle UEFI or BIOS/legacy booting with the CSM option. I can choose UFB, Fast Boot, or Disabled with Fast Boot mode. Secure Boot and installing its keys is available.

    As you said, in order to UEFI boot, enabled via Secure Boot (or CSM alone) the video source must support the UEFI GOP protocol. Otherwise after POST, no video, a black screen. My ASRock board catches this problem, and displays an error message, so at least you know what happened.

    The Intel on-CPU graphics supports GOP, as far back as Sandy Bridge CPUs/HD Graphics 3000 at least.

    I don't know to what extent AMD integrated graphics support GOP, or AMD/ATI video cards.

    Nvidia GTX 700 and 600 series cards can support GOP, with the correct VBIOS, as you said. All earlier Nvidia cards, the 500 series and earlier, cannot be updated with a VBIOS to support GOP. It depends on the manufacture of your Nvidia based 600 or 700 card if the GOP VBIOS is standard with the card. I know all EVGA 700 series cards support GOP out of the box. EVGA 600 series cards all need a VBIOS update to support GOP, which EVGA will send you on request.

  3. #3
    ViRuS2k is offline Member
    Join Date
    Jun 2009
    Location
    Uk
    Posts
    126

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Gigabyte z87 OC board X05 bios.

    Secure boot issues.

    ---------------------------------------

    Basicly i can get secure boot enabled in the bios but when i enable it and set default keys
    my hdd`s vanish, the only way to get them back is to enable CMS support, then when i reboot CMS is disabled again
    its cause secure boot wants to enable usermode when i enable it there for disabling cms support there for my hdd`s vanish from boot selection.
    if i enable secure boot in setup mode then i can access hdd`s but for some reason in the bios it still says secure mode : disabled.

    something finky dinky going on with this bios and its so annoying cause gigabyte support are doing nothing for a feature we payed for...... makes my head boil might have to buy a new motherboard.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Quote Originally Posted by ViRuS2k View Post
    Gigabyte z87 OC board X05 bios.

    Secure boot issues.

    ---------------------------------------

    Basicly i can get secure boot enabled in the bios but when i enable it and set default keys
    my hdd`s vanish, the only way to get them back is to enable CMS support, then when i reboot CMS is disabled again
    its cause secure boot wants to enable usermode when i enable it there for disabling cms support there for my hdd`s vanish from boot selection.
    if i enable secure boot in setup mode then i can access hdd`s but for some reason in the bios it still says secure mode : disabled.

    something finky dinky going on with this bios and its so annoying cause gigabyte support are doing nothing for a feature we payed for...... makes my head boil might have to buy a new motherboard.
    You can't just enable Secure Boot, etc, without having a Windows installation that was configured for UEFI booting, which is required for using Secure Boot.

    That is, the OS drive is formatted as GPT, with Secure Boot enabled (or CSM disabled) during the OS installation. In that configuration, drives will appear in the boot list with "UEFI..." as part of the drive's name, and you'll also see the drives listed with "AHCI..." at the beginning of the drive's name. If you're using Windows 7, the installation media must be configured on a USB flash drive in a certain way for the installation to be done in UEFI booting mode. Of course there is also the necessity to have a video source that is GOP compatible.

    There is nothing wrong with your board's BIOS, and it is changing things back to Secure Boot disabled because your current OS installation is not right for UEFI booting. At least it seems it is, given the limited description of your PC.

  5. #5
    ViRuS2k is offline Member
    Join Date
    Jun 2009
    Location
    Uk
    Posts
    126

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Quote Originally Posted by parsec View Post
    You can't just enable Secure Boot, etc, without having a Windows installation that was configured for UEFI booting, which is required for using Secure Boot.

    That is, the OS drive is formatted as GPT, with Secure Boot enabled (or CSM disabled) during the OS installation. In that configuration, drives will appear in the boot list with "UEFI..." as part of the drive's name, and you'll also see the drives listed with "AHCI..." at the beginning of the drive's name. If you're using Windows 7, the installation media must be configured on a USB flash drive in a certain way for the installation to be done in UEFI booting mode. Of course there is also the necessity to have a video source that is GOP compatible.

    There is nothing wrong with your board's BIOS, and it is changing things back to Secure Boot disabled because your current OS installation is not right for UEFI booting. At least it seems it is, given the limited description of your PC.
    Right im getting an idea of what your talking about the problem is i can not format my hdd with GPT cause when i enable secure boot no drives show up not even the install drive so i cant install the os then format it to GPT within the software....
    very strange stuff lol

  6. #6
    ViRuS2k is offline Member
    Join Date
    Jun 2009
    Location
    Uk
    Posts
    126

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    update : ok i managed to get my disk to show up as UEFI and boot under secure mode, but it keeps looping back the my bios or looping back to say no boot device found enter setup ect.
    so i went into windows 7 and formated my ssd drive as a GPT partition.
    but still when secure mode is enabled it will not detect a hdd it should have detected my ssd as uefi compatible being GPT partitioned but still when i boot it loops back to bios when i press any key to run setup or it says no device found or no disk found......

    im at a loss so fkin complicated to get this working.

  7. #7
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Quote Originally Posted by ViRuS2k View Post
    update : ok i managed to get my disk to show up as UEFI and boot under secure mode, but it keeps looping back the my bios or looping back to say no boot device found enter setup ect.
    so i went into windows 7 and formated my ssd drive as a GPT partition.
    but still when secure mode is enabled it will not detect a hdd it should have detected my ssd as uefi compatible being GPT partitioned but still when i boot it loops back to bios when i press any key to run setup or it says no device found or no disk found......

    im at a loss so fkin complicated to get this working.
    There you go:
    UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Help Forums
    Regards

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Quote Originally Posted by ViRuS2k View Post
    Right im getting an idea of what your talking about the problem is i can not format my hdd with GPT cause when i enable secure boot no drives show up not even the install drive so i cant install the os then format it to GPT within the software....
    very strange stuff lol
    The link Teddybehr posted will give you more information about UEFI booting. It's a great guide, one among others on that same site that I used to learn how to install a UEFI booting OS. While it is the best I've found, it still uses Secure Boot as the "switch" to enable UEFI booting, which works but is not necessary if you have access to the CSM option.

    You simply cannot transform a non-UEFI booting Windows installation into a UEFI booting one simply by formatting the OS drive as GPT after the OS is installed. Or even before the OS is installed, Windows formats the drive for you once it recognizes a UEFI booting installation is intended. It will GPT format, plus create an EFI system partition which is required for UEFI booting, plus add a "safety MBR" partition so the OS will boot in both UEFI and legacy mode. Read the guide and the guide on creating a UEFI booting Windows installation.

    Sorry but I cannot write up an entire guide for installing an OS in UEFI booting mode in a forum post. The loop back to the BIOS is caused by incompatibilities between the BIOS settings and the current state of your drives. If they are not completely "cleaned", with no remaining partitions of a usual BIOS boot (MBR for example), the BIOS will find them (fortunately) and put you back into the BIOS to disable Secure Boot.

    Also, if you use Windows 7, you cannot use Ultra Fast boot, since that is only supported by Windows 8.

    Once you do this once or twice, it is really not that strange or exotic, just different. But you can see why there is so little information in the BIOS or manuals about this, since it takes some explanation, and I wonder if the manual authors understand all of it.

  9. #9
    Join Date
    Dec 2010
    Location
    Near Toronto but not in it
    Posts
    625

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    Quote Originally Posted by parsec View Post
    Also, if you use Windows 7, you cannot use Ultra Fast boot, since that is only supported by Windows 8.
    IMO Win8 Ultra Fast Boot = Win7 Sleep Mode

    Vin
    Main Rig
    OS = Win8.1
    CPU = i7-980X @ 4.17Ghz 144x29 cooled by custom Loop
    Mem = 12GB 2000Mhz corsair Dominator GT at 2010Mhz @ 9-10-9-27-2T
    MB = Gigabyte GA-X58A-UD5 v1.0 with F6 Bios - Dead Board
    MB = EVGA X58 Classified3 e770
    GPU = 2x Sapphire r9 290x in xfire
    HD = 4x PNY 120GB Raid 0
    Storage = 2TB WD Black
    PSU = EVGA SuperNOVA 1300w
    Case = Cooler Master HAF-X 945

    HTPC / Home Server
    OS = Win7 64Bit running XBMC HTPC Front end with Windows Server 2011 Virtual Machine with 8GB ram assigned for homer server with exchange
    CPU = AMD 1090T
    Mem = 16GB 1600Mhz Kingston RED Limited Edition running at 1600Mhz
    MB = Gigabyte 790FXTA-UD5
    GPU- EVGA GT210
    HD = too many to count, but about 5TB of storage all together including backup
    PSU = Corsair TX750
    Case = Too embarrassed to mention.

  10. #10
    ViRuS2k is offline Member
    Join Date
    Jun 2009
    Location
    Uk
    Posts
    126

    Default re: Win 8.1-Secure Boot isnt configured correctly- Water Mark- Not able to access BIOS after enable Secure Boot [Solved]

    thankyou guys ;)
    i was just being dumb lol, i couldnt get my head around it all, my mistake was not creating the OS and booting up in UEFI first then after installed and ssd formated to uefi compatible then i needed to enable secure boot mode
    then it would give me a new boot option called BOOTMANAGER EUFI Samsung 640 Evo SSD then i could boot with it ;)
    holy **** at the speed of bootup lol

    also good news is i have no issues what so ever with gigabyte z87 X05 when it comes to windows 8.1 and its watermark issues with secure mode not configured and the like.



    image of my desktop, everything working perfectly :D

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •