Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: GA-X79S-UP5-WIFI: RAID gone after updating to F4 BIOS




  1. #1
    CyberShadow is offline Junior Member
    Join Date
    Feb 2013
    Location
    Moldova, Eastern Europe
    Posts
    2

    Default GA-X79S-UP5-WIFI: RAID gone after updating to F4 BIOS

    System setup:
    - 2 SSDs in RAID 0, plugged into the white SATA3 ports - contains system
    - 4 SATA HDDs in RAID 10, plugged into the gray SAS ports
    - IRST/RSTe setting was set to IRST (RSTe had no RAID TRIM pass-through until recently)

    My goal was to upgrade my system with a i7-4960X processor. After installing the CPU, the system would only power up for a second, shut down for a few seconds, and repeat. I quickly discovered that I needed to update my BIOS to the F4 version.

    After replacing the old CPU back, updating the BIOS to F4, and configuring the BIOS RAID settings, I could boot, however my HDD RAID 10 was gone - I could see no mention of neither the array nor the HDDs anywhere, incl. Windows device manager, the IRST management console, or BIOS setup.

    The only time I saw the BIOS mention the HDD RAID is immediately after resetting the BIOS settings to optimized defaults. The defaults, however, put the controller in AHCI mode, so even though I see the HDD RAID during bootup and when pressing Ctrl+I, I can't boot because AHCI mode precludes booting from the SSD RAID 0.

    Things I have tried:
    - Updating to F5a, the latest Beta BIOS (same problem as F4)
    - Trying virtualfred's F4x and F5a mods (F4x does not support the new CPU, and the F5a mod has same problem as F4)
    - Switching to RSTe (Windows BSoDs during boot)

    Things I've yet to try:
    - Move the SSDs to SAS ports (however I'd lose SATA3)
    - Move the HDDs to the SATA ports (however then I'd lose the optical drive, as the SAS ports don't support optical drives)
    - Fix the RSTe Windows boot BSoD by manually installing the RSTe drivers from WinPE

    Curiously, if I reset BIOS settings to optimized defaults (so I see my HDD RAID 10 during boot), then change the SATA Mode setting to RAID, reboot, and change SATA Mode back to AHCI, it does not behave in the same way - I don't see any storage controller initialization screen (with the Ctrl+I invitation) at all during boot-up. I've saved the BIOS profiles (optimized default, and after changing SATA mode to RAID and back to AHCI), and comparing them shows 12 different bytes, but I have no clue what they could mean.

    I am going to keep experimenting, but if anyone has any ideas I'd love to hear them. I suppose I could always downgrade my BIOS and swap back the old CPU, and wait for a BIOS update which fixes this problem.
    Last edited by CyberShadow; 12-08-2013 at 01:56 PM.
    trimcheck: SSD TRIM checker | cacheset64: >4GB Windows cache

  2. #2
    CyberShadow is offline Junior Member
    Join Date
    Feb 2013
    Location
    Moldova, Eastern Europe
    Posts
    2

    Default Re: GA-X79S-UP5-WIFI: RAID gone after updating to F4 BIOS

    OK, I've done some more experiments, and as far as I can tell the SAS ports now don't work AT ALL with SATA drives, if you enable IRST/RSTe. I don't have any SAS drives, so the SAS ports are either completely disabled or you are now required to use SAS drives only?

    I've also tried playing a bit more with the weird default configuration mentioned in the first post. If you clear the configuration to optimized defaults, the BIOS shows that the controller is set to AHCI mode - however, RSTe will start up and detect all drives and RAID arrays plugged into SAS ports. HOWEVER, this configuration seems to be very unstable - although booting might be successful, the system will inevitably hang, and upon reboot you will find the drives as failed (and possibly, the array marked as unbootable).

    So it looks as if the F4 BIOS does have the capability to access SATA drives and arrays plugged in SAS ports, however the functionality is buggy, and it is not possible to enable it in the BIOS settings (although it is left enabled in the optimized defaults).

    Does anyone know anything at all about this?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •