Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: GA-Z87-HD3 No video from R9-280x




  1. #1
    Join Date
    Jul 2014
    Location
    Uruguay
    Posts
    2

    Default GA-Z87-HD3 No video from R9-280x

    Hello!
    Whenever I do a cold boot, no video signal comes out. Windows starts just fine though, I can hear the logon sound.
    If I connect the HD4600 instead, everything works just fine.

    In order for the R9 280x to work, I have to use the computer for a couple of hours and then shut it down and plug in the 280x.

    If I plug the 280x on the pci-e x4 slot, it works right from the start.

    I did send my video card to RMA and they told me it is working perfectly.

    I didn't have any problems with my previous setup using the same PSU.

    Also, recently tried my old 8800GT on this same rig and it works great.
    Can somebody give me a hand here, please?
    i7-4770k @3.9Ghz \ GA-Z87-HD3 F7 / XFX R9-280x \ 2x8GB HyperX Predator 2133Mhz / OCZ Vector 120GB + Samsung Spinpoint F1 \ HD103UJ 1TB / Sentey Arvina (ew) \ Sentey HBP1100-SM / CM Inferno \ Rosewill CherryMx Blue / Samsung SyncMaster P2370 \ Thonet & Vander Hoch

  2. #2
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: GA-Z87-HD3 No video from R9-280x

    Try setting in the BIOS pcie2 and see if it works.
    Not sure why some cards are tricky to get going, but sometimes lowering the setting helps.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  3. #3
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: GA-Z87-HD3 No video from R9-280x

    any bios switch on those 280 graphic cards? could try the other bios position

    GA-Z87-HD3 - F8c Z87HD3.8c

    tried latest beta bios for the motherboard?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  4. #4
    Join Date
    Jul 2014
    Location
    Uruguay
    Posts
    2

    Default Re: GA-Z87-HD3 No video from R9-280x

    Hey, thanks for answering!

    Quote Originally Posted by boondocks View Post
    Try setting in the BIOS pcie2 and see if it works.
    Not sure why some cards are tricky to get going, but sometimes lowering the setting helps.
    I've tried switching around those pcie settings, but no luck.

    Quote Originally Posted by wazza300 View Post
    any bios switch on those 280 graphic cards? could try the other bios position

    GA-Z87-HD3 - F8c Z87HD3.8c

    tried latest beta bios for the motherboard?
    I've searched and searched but couldn't find how to flash a new bios on the 280x. I've never flashed or switched bios on a graphic card, is it complicated?

    Regarding motherboard's bios:

    I currently have F7. Didn't try any others because F7 is the last one on Gigabyte's website.
    I guess I could try F8c, I'm just scared of the outcome. Is there any way to fix it if the beta bios doesn't work? Like if it doesn't even post... or some stuff like that.

    ----------------------

    Some additional information:

    I've tried an old nVIDIA 8800GT on the pci-e x16 slot and it worked perfectly.
    Also tried another PSU (ANTEC HCG-850M) but the problem persisted.

    I'm currently using an old i7-930 with an Intel motherboard, and the 280x works just fine on the pci-e x16 slot.

    I'M PUZZLED.
    i7-4770k @3.9Ghz \ GA-Z87-HD3 F7 / XFX R9-280x \ 2x8GB HyperX Predator 2133Mhz / OCZ Vector 120GB + Samsung Spinpoint F1 \ HD103UJ 1TB / Sentey Arvina (ew) \ Sentey HBP1100-SM / CM Inferno \ Rosewill CherryMx Blue / Samsung SyncMaster P2370 \ Thonet & Vander Hoch

  5. #5
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: GA-Z87-HD3 No video from R9-280x

    No one is suggesting flashing the video card bios, only the motherboard bios. There's nothing hard or tricky about it, just read the stickies up top if you don't know how.
    Wazza suggesting flipping the bios switch on the video card, worth a try I guess.

    If none of this fixes your problem I suggest you pull the battery for 15 minutes.
    Another thing to try is hotplugging the monitor cable to the card, I've had this work with hdmi not sure about others.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  6. #6
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: GA-Z87-HD3 No video from R9-280x

    you'll be ok with latest beta bios,if it doesn't cure it you can simply flash back to your previous bios

    download/extract bios to usb memory stick and update the bios through qflash,its a simple process
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •