Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: USB 3.0 ports not working in Kubuntu 14.04 64 bit




  1. #1
    Bartman2589 is offline Junior Member
    Join Date
    Jul 2014
    Location
    United States
    Posts
    2

    Unhappy Solved! - Need Help - GA-970A-UD3P USB 3.0 ports not working in Kubuntu 14.04 64 bit

    Ok, just bought a GA-970A-UD3P board to replace my old GA-78LMT-S2P that had both the onboard sound and the one and only PCI slot fail on it one after the other (board is still under warranty so I'm going to RMA it to use for another system later), but I'm having a few problems getting things working right on this new board.

    After almost pulling out all of my hair trying to figure out how to get USB 2.0 and Ethernet working on this board in Kubuntu I finally stumbled on having to enable the IOMMU feature in the BIOS to get them working. But now my USB 3.0 ports don't work.

    If I enter 'dmesg | grep xhci' at a shell prompt I get:
    Code:
    [    1.666938] xhci_hcd 0000:02:00.0: xHCI Host Controller
    [    1.666942] xhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 8
    [   19.169478] xhci_hcd 0000:02:00.0: can't setup: -110
    [   19.169481] xhci_hcd 0000:02:00.0: USB bus 8 deregistered
    [   19.169543] xhci_hcd 0000:02:00.0: init 0000:02:00.0 fail, -110
    [   19.169546] xhci_hcd: probe of 0000:02:00.0 failed with error -110
    So clearly the kernel is seeing the USB 3.0 ports but it's failing to enable support for them. I've tried setting the 'IOMMU=soft' kernel option in grub along with disabling IOMMU in the BIOS (and loading optimized defaults in the BIOS) as indicated by another post I stumbled upon claiming that this should take care of the issue but it doesn't seem to work for me (unless maybe I'm missing something).

    At this point I'm almost wishing I had just bought another GA-78LMT-S2P instead, but I wanted something that would at least let me use one or two PCIe slots eventually since the board layout for the GA-78LMT-S2P is such that any decent video card (which are pretty much all double wide now) covers the one and only PCIe slot on the board preventing it from being used, leaving only the regular PCI slot available (really poor design Gigabyte! And what's worse they duplicated that poor design on the updated USB 3.0 capable version of that board), as it is even with this board one of the PCIe slots is covered by my video card, but at least there are 3 total on this board.

    Anyway, I'd appreciate any help anyone could provide.

    Thanks,
    Bartman2589

    UPDATE: Well turns out the problem in part was that my one and only USB 3.0 device is not really completely linux compatible (linux identifies it at ASMedia model AS2105, in this case it features the ASM1053 chipset (not the E version that's supposed to be more compatible with things though unfortunately)). And setting the IOMMU=soft kernel boot parameter actually does enable the USB 3.0 ports just fine (as far as I can tell at least since USB 2.0 devices are now properly detected when connected to the USB 3.0 ports, I had only tested it with the annoyingly uncooperative drive). Said drive seems to work just fine with USB 2.0 ports though in Linux, so apparently there's a problem with it's USB 3.0 support in the ASM1053 chipset (or a problem in the linux kernel's support of that chipset maybe).

    I don't know how to mark this as Solved/Closed though (will try changing the title to include "Solved!" anyway).
    Last edited by Bartman2589; 07-14-2014 at 10:06 AM. Reason: Found the problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •