Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Z77X-UD3H Back USB Ports Not Working




  1. #1
    DeederMc is offline Junior Member
    Join Date
    Mar 2015
    Location
    Los Angeles, CA
    Posts
    1

    Default Z77X-UD3H Back USB Ports Not Working

    I was screwing around - removing programs and drivers trying to get a little extra speed - and now my back USB ports have stopped working. I've tried removing all the USB drivers in the device manager and letting windows rediscover them - no luck. I used the @BIOS to update to whatever it updates, then I downloaded this
    http://download.gigabyte.us/FileList...intel_usb3.exe
    and this
    http://downloadmirror.intel.com/2112...ler_Driver.zip
    and this
    http://www.via-labs.com/archive/doc/..._V4.70C_AP.zip
    and installed them - none solved the problem. What should I try next? Thanks for your help.
    -Dee

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z77X-UD3H Back USB Ports Not Working

    Do you have the On/Off Charge utility installed?

    If you do, uninstall that and then the two USB 3.0 drivers too. Then install the USB 3.0 drivers before you install On/Off Charge again.

    Otherwise you could try running a Repair from your Windows installation media.

    If all this fails, you're looking at a fresh Windows installation.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •