Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)




  1. #1
    genegold is offline Member
    Join Date
    Jun 2009
    Location
    MT
    Posts
    138

    Default BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Weird problem: Frequently get boot errors on way to Win 8.1, and when go into BIOS, find that boot option #1 setting for Samsung 850 EVO Pro SSD system drive has switched to something else (Samsung is in SATA3 Port 0). Usually takes a couple of boot option resets to get it to hold and the computer to boot normally into Windows. Doesn't happen every time, but often. F7 BIOS (UEFI). Mobo is revision 1.1. CPU is not overclocked.

    Background: Switched from GA-Z68X-UD3H board to the Z97X-UD5H-BK in early May and soon after that switched system drives from a 128gb Plextor SSD to a 256gb Samsung 850 EVO Pro (the latter was cloned, then did an in-place repair install, which now looks was unnecessary). Soon after, I started having frequent boot errors that shouldn't have been occurring, with one or more of the following: disk read error, Boot\BCD error, Windows boot stalling, MBR Error 1 suggesting to boot from a floppy drive (don't have one), blank screen. After those, usually one to three reboots led/leads to a successful start up. At some point, I decided to check the BIOS settings and discovered two things:

    - Boot #1 option has changed from the Samsung SSD, typically to either the Plextor DVD drive, or by dropping the HDD/DVD drives from the list and showing only Samsung, Canon and disabled.

    - After resetting the boot options, it takes at least another reset/save to get them to hold, tho saved each time. After the first reset, BIOS boot options typically only show Samsung/Canon/disabled as boot options, as just mentioned. It takes another reset for all the drives to show in the lists (all drives are listed under Peripherals > SATA configuration, no matter what). The reboot in between is typically the one that shows a blank screen.

    I got a support ticket with Gigabyte and they suggested disconnecting all the USB connections except the mouse as the starting point for a test. But it made no difference. In fact, it took four boot option resets to get to Windows. That's when I figured it worth posting here.

    Any ideas? Thanks,
    Last edited by genegold; 07-01-2015 at 04:36 AM.
    ASRock Z97 Extreme6 / Intel i7-4790K
    32 GB G.Skill DDR3 2133 RAM (Ares 4x8gb)
    EVGA GTX950 SC
    Prolimatech Megahalems Rev. C cooler w/ Nexus Silent Fan
    Seasonic X650 PSU
    Samsung Pro 850 256GB SSD (system drive)
    SanDisk ExtremePro 480, Seagate 1TB, 2TB and 2x 3TB SATA 6Gb/s
    Plextor PX-891SA CD/DVD Writer/Player
    Dell U2412M Monitor (1920x1200)
    IBM Model M keyboard / Bornd M120 wireless mouse
    Thermaltake F31 Case
    Canon MP640 / Brother HL-2270DW printers
    Audio system: Dac + Powered speakers + USB card + LPS + power cond./distrib.
    Windows 10 Pro x64

  2. #2
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Quote Originally Posted by genegold View Post
    Weird problem: ...

    Any ideas? Thanks,
    Have you tried the latest beta bios?
    Z97XUD5HBK.8a

    Make sure that your drive is first in your drive priority options.
    Then it should show first in your boot priority option.
    Install the latest RST driver (in top of the default win 8.1 one)
    Oh and make sure you have the latest SSD firmware installed (with Samsung Magician)
    Your OS Win 8.1 is installed in Legacy mode (mbr), not UEFI mode (disk would be partitionned GPT) so be sure to:
    - enable CSM support
    - disable secure boot
    - disable fast boot

    Will check other possible solution if that doesn't work.
    regards
    Last edited by Teddybehr; 07-09-2015 at 11:50 AM. Reason: typo
    Board: GA-Z77X-UD3H Rev 1.0 BIOS: 20e modded CPU: Intel i5-3570k Memory: Samsung MV-3V4G3D/US 4X4GB @1866Mhz 9-9-9-24 1T
    GPU: EVGA GTX 980 FTW SSD: Samsung 950 Pro NVMe M.2 256 GB (Addonics 4x card interface) , Intel 730 240 GB, Samsung EVO 840 240 GB X2,
    16 TB iSCSI 2XRAID0 2XRAID1 (Hitachi HDD, LUN) QNAP TS-469L PSU: Seasonic X-1250 KB:Log. G110 Mouse: Log. G502
    OSes: Win 8.1 x64 UEFI/Win 7 x64 UEFI Dual Boot VM: K Linux, OSX Leopard, Win 10, Win XP, HP Integrity (rem), Whonix Other: HP Proliant server
    Other interface: Pangolin QM2000.NET Lasers controller

  3. #3
    genegold is offline Member
    Join Date
    Jun 2009
    Location
    MT
    Posts
    138

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Quote Originally Posted by Teddybehr View Post
    Have you tried the latest beta bios?
    Z97XUD5HBK.8a

    Make sure that your drive is first in your drive priority options.
    Then it should show first in your boot priority option.
    Install the latest RST driver (in top of the default win 8.1 one)
    Oh and make sure you have the latest SSD firmware installed (with Samsung Magician)
    Your OS Win 8.1 is installed in Legacy mode (mbr), not UEFI mode (disk would be partitionned GPT) so be sure to:
    - enable CSM support
    - disable secure boot
    - disable fast boot

    Will check other possible solution if that doesn't work.
    regards
    Thanks for the reply. It appears that in the process of switching SSDs, I lost UEFI along the way.

    Here's what I've done:
    - flashed 8a bios
    - boot order has been correct, except when something has thrown it off
    - installed latest RST driver and then reminded myself why RST is disabled in bios: computer won't start with it enabled (others have found that too)
    - Samsung firmware is current; update of latest Magician pending
    - What are CSM support and secure boot? Why not fast boot?

    What I've done so far has had zero effect. Btw, after reattaching the SATA cable I had about 20 good boots with maybe one "no disk found" among them. Then this afternoon (Wed), when the computer seemed to be having some slowness, I rebooted and the whole thing started again. My hunch is that this is going to take a reinstall of Windows to find out if it's the Win 8.1 cloning, the Samsung SSD or something about the BIOS.
    Last edited by genegold; 07-09-2015 at 12:33 PM.

  4. #4
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Quote Originally Posted by genegold View Post
    Thanks for the reply. It appears that in the process of switching SSDs, I lost UEFI along the way.

    Here's what I've done:
    - flashed 8a bios
    - boot order has been correct, except when something has thrown it off
    - installed latest RST driver and then reminded myself why RST is disabled in bios: computer won't start with it enabled (others have found that too)
    - Samsung firmware is current; update of latest Magician pending
    - What are CSM support and secure boot? Why not fast boot?

    What I've done so far has had zero effect. Btw, after reattaching the SATA cable I had about 20 good boots with maybe one "no disk found" among them. Then this afternoon (Wed), when the computer seemed to be having some slowness, I rebooted and the whole thing started again. My hunch is that this is going to take a reinstall of Windows to find out if it's the Win 8.1 cloning, the Samsung SSD or something about the BIOS.
    I wrote:
    "Install the latest RST driver" NOT enable RST in the BIOS
    RST drivers package contain AHCI, RAID and software.
    You are probably in AHCI mode (at least you should be) thus the AHCI driver install itself

    Your Win 8.1 is install in Legacy mode (since you clone it from a system that do not support UEFI) so:
    - Run msinfo32.exe and on the Right pane check "BIOS mode". It will most likely show: Legacy (not UEFI)
    - you need to enable "Compatibility Support Module" (CSM)
    - disable fast boot since it is a UEFI option
    - disable secure boot since it is a UEFI option

    If you do a fresh install a Win 8.1 do it in UEFI mode IF your graphic card support UEFI booting and only IF (Please post your specs next time)
    Assuming it is the case:
    - disable CSM support
    Follow this guide carefully including removing partition before installing:
    UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with

    Good luck and come back if no resolution on SSD boot order, or anytime
    regards
    Last edited by Teddybehr; 07-09-2015 at 02:55 PM. Reason: clarification

  5. #5
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Just to be sure,
    Each time you plug or unplug some hardware or you flash the BIOS, ALWAYS
    - Clear your CMOS (reset bios)
    - "Load optimized settings" in the bios then SAVE, reboot and enter BIOS settings again and finalize your settings, SAVE and Reboot.

    Then you're good to go.
    Hope it helps
    Last edited by Teddybehr; 07-09-2015 at 03:27 PM. Reason: typo

  6. #6
    genegold is offline Member
    Join Date
    Jun 2009
    Location
    MT
    Posts
    138

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Thanks. There's a Windows 8 features setting in BIOS that I had set to "other OS" for a good reason that I can't recall now. When set to Win 8, CSM then shows ("always"). Secure boot seems disabled by default because I'm not using a password (?). Fast/Ultra Fast boot do work with my setup. Except for the cable connection and monitor (DVI) and LPS to a USB card, all of the external hardware is USB based, which shouldn't require resetting the BIOS.

    All of these changes have had no effect on the problem.
    Last edited by genegold; 07-09-2015 at 11:04 PM.
    ASRock Z97 Extreme6 / Intel i7-4790K
    32 GB G.Skill DDR3 2133 RAM (Ares 4x8gb)
    EVGA GTX950 SC
    Prolimatech Megahalems Rev. C cooler w/ Nexus Silent Fan
    Seasonic X650 PSU
    Samsung Pro 850 256GB SSD (system drive)
    SanDisk ExtremePro 480, Seagate 1TB, 2TB and 2x 3TB SATA 6Gb/s
    Plextor PX-891SA CD/DVD Writer/Player
    Dell U2412M Monitor (1920x1200)
    IBM Model M keyboard / Bornd M120 wireless mouse
    Thermaltake F31 Case
    Canon MP640 / Brother HL-2270DW printers
    Audio system: Dac + Powered speakers + USB card + LPS + power cond./distrib.
    Windows 10 Pro x64

  7. #7
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Quote Originally Posted by genegold View Post
    Thanks. There's a Windows 8 features setting in BIOS that I had set to "other OS" for a good reason (when your OS is not installed in UEFI mode) that I can't recall now. When set to Win 8, CSM then shows ("always"). Secure boot seems disabled by default because I'm not using a password (?) Those are windows 8.1 secure boot keys. Do not play with that unless you are familiar with Secure Boot. Fast/Ultra Fast boot do work with my setup (NO it doesn't, Turn it off). Except for the cable connection and monitor (DVI) and LPS to a USB card, all of the external hardware is USB based, which shouldn't require resetting the BIOS (YES you should).

    All of these changes have had no effect on the problem.
    Hi,

    See above comments in red.

    Again, you are trying to use Windows 8.1 UEFI features in BIOS with a Windows 8.1 operating system which was NOT installed in UEFI mode. That create conflicts. When you set your OS option in BIOS to "Win 8" Your BIOS is searching for a UEFI boot device (with EFI boot loader) and since your SSD (OS) is NOT setup in UEFI it will skip it and probably end up with the DVD ROM as your first boot option (since DVD Rom is the way from which someone will install widows 8.1 in UEFI).

    So make up your mind if you want to do a fresh install of Win 8.1 in UEFI mode or if you're keeping your current config.

    Note: Your graphic card Sapphire HD7750 do not support UEFI booting but you can still install Win 8.1 in UEFI boot mode (read the above guide about installing Win 8.1 in UEFI, and enable CSM support putting it at "always"). I would advise you do a CLEAN with DISKPART to reinitialize the SSD (which is initialized now in MBR but need to be initialize in GPT like all your disk in win 8.1 UEFI mode). That will erase all your data on your system disk. You can always convert a MBR non system SSD (or HDD) to GPT in disk management section of Win 8.1. That being said, in your case, even if your Win 8.1 OS is installed in UEFI mode you will not be able to use some UEFI features like secure boot and ultra fast boot because you will not boot in full UEFI mode (CSM support disabled) because you graphic card do not have a GOP and will boot using an option ROM (opROM) instead of full efi gop driver.

    If you want to keep your current config:
    Read your manual from around page 53

    - Reset CMOS, Reboot
    - Go back in BIOS and load optimized default settings
    - Set "OS option" to "Other OS"
    - Set "boot mode selection" at "UEFI and Legacy"
    - Set "Storage boot option control" at "Legacy only"
    - Save, reboot, shut down, remove power cord, put back power cord, reboot
    - Go back in your BIOS and finalize settings for your SSD first boot, save, reboot.
    - Install latest chipset driver (important)
    - Install latest RST driver
    - Install USB driver if Win 8.1 didn't (especially USB 3.0)
    - Install graphic drivers
    - Install other drivers

    DO not play with UEFI settings features in your BIOS. That is for a Win 8 (or 7 under condition or 8.1 or 10) installed in UEFI mode (which is NOT your case)

    That should do it.
    If not, go back to Gigabyte support and open a ticket or contact them.
    Hope it helps
    Last edited by Teddybehr; 07-10-2015 at 05:15 AM. Reason: typos

  8. #8
    genegold is offline Member
    Join Date
    Jun 2009
    Location
    MT
    Posts
    138

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    I'm getting ready to leave for the weekend and will look again next week. I do think there's a disconnect here, but want to go through the steps - virtually all of which I've done already! - to see one way or the other when I have time.

    I've had a ticket open with Gigabyte on this for several weeks, but they couldn't figure it out. Which is why in the midst of it I posted here.

  9. #9
    Teddybehr's Avatar
    Teddybehr is offline Member
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    159

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    Quote Originally Posted by genegold View Post
    I'm getting ready to leave for the weekend and will look again next week. I do think there's a disconnect here, but want to go through the steps - virtually all of which I've done already! - to see one way or the other when I have time.

    I've had a ticket open with Gigabyte on this for several weeks, but they couldn't figure it out. Which is why in the midst of it I posted here.
    Please do not hesitate to come back here. We will do our best to help you.
    regards

  10. #10
    genegold is offline Member
    Join Date
    Jun 2009
    Location
    MT
    Posts
    138

    Default Re: BIOS Disk Boot Option settings don't hold (GA-Z97X-UD5H-BK)

    I completed the list through "Go back into your BIOS..." and the rest had already been done (all but one done before this thread started, as were almost all of the settings). No effect - boot problem still there.

    I suspect the problem lies with the three month old Samsung drive or with the Windows boot file being corrupted or not recognized for some reason much of the time. I can literally run 25 starts that fail, and then leave the computer off for awhile and it starts up on first or second try. A strange thing is when I run "bootrec /rebuildbcd" (from Windows install media), it usually recognizes one Windows installation and gives me the option to "Add installation to boot list? Yes/No/All." When I answer Yes, the response is "the element can't be found" or something to that effect. Not sure what to make of it, except either the SSD is bad or the cloning of the old SSD wasn't successful. Thanks,
    ASRock Z97 Extreme6 / Intel i7-4790K
    32 GB G.Skill DDR3 2133 RAM (Ares 4x8gb)
    EVGA GTX950 SC
    Prolimatech Megahalems Rev. C cooler w/ Nexus Silent Fan
    Seasonic X650 PSU
    Samsung Pro 850 256GB SSD (system drive)
    SanDisk ExtremePro 480, Seagate 1TB, 2TB and 2x 3TB SATA 6Gb/s
    Plextor PX-891SA CD/DVD Writer/Player
    Dell U2412M Monitor (1920x1200)
    IBM Model M keyboard / Bornd M120 wireless mouse
    Thermaltake F31 Case
    Canon MP640 / Brother HL-2270DW printers
    Audio system: Dac + Powered speakers + USB card + LPS + power cond./distrib.
    Windows 10 Pro x64

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •