Well, I think my X99 UD5 Wifi bit the dust today. Had it powered up earlier, doing some internet uploads and downloads. Powered down..shut off the UPS and that was it. Never powered up again. Normally, when the PSU is feeding the board, the power button on the motherboard is lit. It is dark. Tested the PSU with paper clip...all good. Also installed a second PSU (HX 750)...still no light, nor power. Gonna have to chat with Gigabyte in the morning and see how fast we can turn a replacement board around. No matter what I try...the board just doesn't take power. One oddity. If I unplug the 24 pin power connector to the board...and then plug it in...the power button flashes for a split second and goes out. Removed all peripherals...still dark. No power to the board, even though the PSU works.



X99-UD5 Wifi
i7 5820K
16 GB of Crucial DDR4-2400
Corsair XH850

All in all...I have tried taking the board out of the case...nothing. Can't seem to get power to the MB at all. Did the paperclip test on both the XH850 and HX750...both PSU's work. Looks like this one is a goner. Will call Gigabyte when they open this morning. Hopefully they can turn something around for me in a timely fashion. Any input on the RMA process with Gigabyte would be a big help.

Thanks