Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product




  1. #1
    xenadi is offline Junior Member
    Join Date
    Jul 2015
    Location
    Tasmania, Australia
    Posts
    7

    Default Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    After confirming that the G1.Assassin 2 was on the windows 10 compatibility list provided by Gigabyte i upgraded to windows 10 only to find that the drivers available on the Gigabyte website wont install as they are for different products (believe e2200 for the killer nic and not 100% sure on the Creative audio).

    Microsoft make up for this shortcoming by providing some drivers via windows update which have resulted in a working system but unfortunately the Creative software (specifically the control panel) will not work as it reports that no device can be found. This means i cant setup SPDIF correctly so i am unable to use my sound system or headset.

    I've tried Daniel_K's Support Park 3.4 but it also results in the same error.

    Anyone have any suggestions?

    p.s. Gigabyte support people, you should update the compatibility list and driver download screen to avoid others wasting their time.

  2. #2
    boe323 is offline Member
    Join Date
    Jul 2011
    Location
    United Kingdom
    Posts
    476

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    I'm with you on this one dude, only thing I can think of for now is uninstall the drivers and use windows generic, but you need to stop the reinstall of the drivers. I'm gutted I cant use the control panel for the effects etc.
    A WHOLE LOT OF NOTHING WORKS PROPERLY

  3. #3
    xenadi is offline Junior Member
    Join Date
    Jul 2015
    Location
    Tasmania, Australia
    Posts
    7

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    I did hear about some registry fixes that got the control panel working, but the site they are posted on (HardwareHeaven) is down so i cant get a copy of them.

  4. #4
    xenadi is offline Junior Member
    Join Date
    Jul 2015
    Location
    Tasmania, Australia
    Posts
    7

    Talking Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Got it to work, untested if it will hold up through multiple reboots.
    All credits to Chrisst who posted this fix on hardware heaven on Feb 21st 2015

    step 1.
    Download the following and import the registry files
    X-FI.zip :: Free File Hosting - File Dropper: File Host for Mp3, Videos, Music, Documents.

    step 2.
    in your drivers install files locate UDAAIM64.exe (may require some unpacking) I would suggest using Daniel_K's Support Pack 3.4

    Enter the full path in between quotes in Start > Run
    e.g. "c:\temp\drivers\audio\.....\UDAAIM64.exe" /S
    and then do the same for UDATEL64.exe (if this file exists in the appropriate driver for your card)
    e.g. "c:\temp\drivers\audio\.....\UDATEL.exe" /S

    Dont open the creative control panel from system tray.
    Access the creative applet control panel through the sound blaster tab on your audio device in sound properties.

    before doing anything else i would suggest going into restore defaults and clean anything carried over with the registry files.

    perform this fix at your own risk, i accept no liability for any damage incurred.

    Best of luck.

  5. #5
    wildenbeer is offline Junior Member
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    8

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Hi, this has been a help already. I've wasted way to much time on this so far.
    One thing: I can't get the LAN to work. It's not even appearing in the adaptors.
    Do you guys have this too? I updated windows btw and didn't download any drivers from gigabyte.

    Can you explain me how you got it to work?

  6. #6
    xenadi is offline Junior Member
    Join Date
    Jul 2015
    Location
    Tasmania, Australia
    Posts
    7

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Quote Originally Posted by wildenbeer View Post
    Hi, this has been a help already. I've wasted way to much time on this so far.
    One thing: I can't get the LAN to work. It's not even appearing in the adaptors.
    Do you guys have this too? I updated windows btw and didn't download any drivers from gigabyte.

    Can you explain me how you got it to work?
    As Killer Networking dont provide any driver updates for the e2100 series anymore just grab the last version available for download.
    https://www.visiontek.com/download-drivers.html have this available for download.

    Did you follow my quick guide above to get your audio working?

  7. #7
    wildenbeer is offline Junior Member
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    8

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Hi, I didn't follow your guide yet, since I'm on unreliable wifi now and wanted to get the LAN fixed first.
    Your tip didn't help me. I get a fatal error during installation. Did you get it to work this way?

    What I meant with help me was that I thought I was doing something wrong somehow and kept doing the same thing over and over.

    I also tried this installer:

    Killer Networking - Driver Downloads

    When I tried the suite, it tells me that there is no killer hardware installed.

  8. #8
    xenadi is offline Junior Member
    Join Date
    Jul 2015
    Location
    Tasmania, Australia
    Posts
    7

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Quote Originally Posted by wildenbeer View Post
    Hi, I didn't follow your guide yet, since I'm on unreliable wifi now and wanted to get the LAN fixed first.
    Your tip didn't help me. I get a fatal error during installation. Did you get it to work this way?

    What I meant with help me was that I thought I was doing something wrong somehow and kept doing the same thing over and over.

    I also tried this installer:

    Killer Networking - Driver Downloads

    When I tried the suite, it tells me that there is no killer hardware installed.
    Killer Networking only provide drivers from e2200 series onwards now so they wont work if you have a g1 assassin 2. The drivers from visiontek install without any issues for me.

    When you say you get a fatal error, is that during the network or audio driver install?

  9. #9
    wildenbeer is offline Junior Member
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    8

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    Quote Originally Posted by xenadi View Post
    Killer Networking only provide drivers from e2200 series onwards now so they wont work if you have a g1 assassin 2. The drivers from visiontek install without any issues for me.

    When you say you get a fatal error, is that during the network or audio driver install?
    Oh man, lucky you! During the network driver install - the registration part at the very end; I see the icon appearing on the desktop but then the installer rolls back.

  10. #10
    wildenbeer is offline Junior Member
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    8

    Default Re: Windows 10 drivers for G1.Assassin 2 on Gigabyte site are for the wrong product

    I also found this in my system information - might be useful?

    Imgur

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •