I have a Z97N-WiFi board with F6 firmware.

I can install Windows 7 Ultimate x64 from a USB stick no problem in Legacy/MBR mode.

However in UEFI/GPT mode I get the dreaded CD/DVD drivers missing during the install and have now spent 3 days trying to find a workaround.

I want to use a 3TB Seagate Constellation drive in Dual Boot Win7Ultx64 - Around 2.5GB/Fedora22(3)x64 - The Rest

due to the way I want to do the partitioning it would be much easier for me to have a 'flat' partitioning scheme, plus UEFI should boot reasonably faster therefore the benefits of using UEFI are fairly apparent.

I created a USB install and that works fine for MBR/Legacy install.

However for the UEFI install I needed to do things little different.

1. The USB stick seems to have to be created as a GPT device else the MoBo won't see it in as a valid UEFI boot device.

2. So created a GPT USB stick and copied files on exactly as before, also adding the boot subdirectory under the efi directory and adding the requied bootx64.efi file from a working x64 machine.

3. The mobo now recognises the UEFI enabled USB stick and boots the windows installer.

4. The installer asks language choice and then after a few seconds presents the "Install Now" option.

5. When selected the installer says "Starting Setup" then comes the dreaded "There is a missing CD/DVD driver...." error message. Googling this leads me to believe this is a 'fallback' MS error message for pretty much anything it cannot handle.

6. Since getting above I have tried....

a) Numerous BIOS settings.
b) DVD Disconnected during install
c) DVD connected and with Gigabyte drivers CD installed.
d) Pretty much every driver on the CD that I can find to see if it's the 'missing' driver.
e) Swapping USB ports (have now tried them all)
f) recreated USB to a different physical stick from a different USB manufacturer
g) Swapped USB to different port when error comes up (I know but some posting somewhere said it worked for them).

I'm now stumped........

Anyone have any solid ideas as to what could be causing this and a definitive solution?

Please do not suggest alternate partition schemes for the drive......I may well want to triple boot this in the future so want to do this as GPT/UEFI.

I have also posted this on the UK Gigabyte support forum so hopefully I'll get an answer from somewhere.

Thanks