Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Does the GA-Z77X-UD5H Motherboard Support Windows 10?




  1. #1
    Join Date
    Aug 2015
    Location
    UK
    Posts
    4

    Default Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    My Gigabyte GA-Z77X-UD5H (BIOS F16G) motherboard works fine in Windows 8.1 Pro in UEFI & Secure Boot Mode.


    Does this motherboard work in Windows 10 in UEFI & Secure Boot Mode?


    It's not on Gigabytes compatibility list but the Windows 10 Compatibility Advisor states my PC is compatible with Windows 10.

  2. #2
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,243

    Default Re: Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    I cant see why not?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/[email protected] 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,651

    Default Re: Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    Yep. I've got one running Windows 10 Home x64.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/[email protected] 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  4. #4
    sixor is offline Junior Member
    Join Date
    Jun 2012
    Location
    venezuela
    Posts
    26

    Default Re: Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    z77x working perfect lol

    why would not?

  5. #5
    MilkyTech is offline Junior Member
    Join Date
    Mar 2020
    Location
    Denver
    Posts
    3

    Default Re: Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    this is an old thread but I am trying to get secure boot to work with windows 10. If anyone has this working with the GA-Z77X-UD5H, please enlighten me the settings...

    I set the bios to Windows 8 to make the secure boot option available (I have my windows 10 set up for UEFI), I enabled secure boot (standard) and it boots fine to windows (although a bit slower than when Other OS is selected) but system information in windows shows secure boot Off. A reboot into bios shows secure boot setting still enabled but secure boot state just above the setting shows disabled.

    Update: I switched the secure boot mode to custom and installed default keys and now bios shows secure boot state as enabled but windows sys info still shows off.

    Update: I updated the Intel ME Firmware then rebooted and its all working now. Shows On in sys info. Not sure if it just needed another reboot or if it needed the newer ME firmware.
    Last edited by MilkyTech; 03-29-2020 at 04:48 AM. Reason: solved

  6. #6
    MilkyTech is offline Junior Member
    Join Date
    Mar 2020
    Location
    Denver
    Posts
    3

    Default Re: Does the GA-Z77X-UD5H Motherboard Support Windows 10?

    this is an old thread but I am trying to get secure boot to work with windows 10. If anyone has this working with the GA-Z77X-UD5H, please enlighten me the settings...

    I set the bios to Windows 8 to make the secure boot option available (I have my windows 10 set up for UEFI), I enabled secure boot (standard) and it boots fine to windows (although a bit slower than when Other OS is selected) but system information in windows shows secure boot Off. A reboot into bios shows secure boot setting still enabled but secure boot state just above the setting shows disabled.

    Update: I switched the secure boot mode to custom and installed default keys and now bios shows secure boot state as enabled but windows sys info still shows off.

    Update: I updated the
    Intel ME Firmware
    then rebooted and its all working now. Shows On in sys info. Not sure if it just needed another reboot or if it needed the newer ME firmware.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •