Had this motherboard for a couple of years now...no major problems until recently. I have had problems the last few days with my two USB3.0 ports, using Windows 10. Just a week ago I was copying files from two different external 3.0 drives. Now the PC won't even recognize them - they don't show up in Windows 10 at all, not under Device Management or Disk Management, which is weird. They work fine with my laptop using USB 3.0, so I know the problem is most likely with my motherboard. I have tried unplugging the PC and letting it sit for several minutes and then plugging the drives back in, have uninstalled the 3.0 under device manager, reinstalled the 3.0 device drivers....to no avail. I am using a couple 3.0 hubs and even tried swapping them around, but the drives don't show up whether hooked up directly to the PC or to a hub.

All other devices seem to work fine. I have a wireless USB keyboard and a wired mouse. The wired mouse did stop working one time when the external hard drive was hooked up.