I'll make a long story shorter.

I was having a hell of a time as about 9 out of 10 times my new X99 UD3P and 5820k would not want to boot into Windows.
It would get to the Gigabyte splash screen and then as it was transferring over to Windows it would just hang there and never load Windows.

I tried countless settings in the BIOS, updated the BIOS, 4 different HDDs / SSDs each with a fresh install of Windows, ran MemTest86 (RAM checked out fine), made sure the RAM was on the officially supported RAM list (it was) and nothing would work.
I even exchanged the board and CPU for a new one and the same thing happened.

I finally found out that if my Playstation 4 controller was plugged into any port the system would hang when launching Windows but if I unplugged it and tried the system would boot with no issue.

I have no problems making sure my PS4 controller is only plugged in when I am using it, I would just like to pass along my experience to possibly help anyone else having boot issues and hopefully see if Gigabyte's tech team can sort that out eventually.