Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: New GA-Z170x Gaming 3 - came with wrong BIOS installed - could be causing issues with GPU?




  1. #1
    Globespy is offline Junior Member
    Join Date
    Sep 2016
    Location
    USA
    Posts
    13

    Default New GA-Z170x Gaming 3 - came with wrong BIOS installed - could be causing issues with GPU?

    I recently built a new gaming rig.
    I purchased the GA-Z170x Gaming 3 (board is a Rev 1.0 - checked the actual board) and noticed that the installed BIOS is F7.
    According to the gigabyte download site, the latest version for my revision is F6. F7 is for the Rev 1.1 board.

    I've been having issues with my EVGA GTX 1080 FTW, essentially it won't report Fan RPM in either GPU-Z or the EVGA or MSI GTX apps, and the fan runs at 100% most of the time. Granted this could be an issue with the graphics card, which is why I'm getting a replacement, but just wondered if the issus is because the motherboard has a BIOS version that's not supposed to be on there?
    I'm thinking of flashing the F6 version downloaded from the gigabyte site and wondered if it's ok to use @BIOS nowadays? I read back in 2008 it was not to be used but that's a long time ago!
    The BIOS has Q-Flash, so if that's better then I can use that instead.

    Appreciate any advice.
    Thanks.

  2. #2
    Globespy is offline Junior Member
    Join Date
    Sep 2016
    Location
    USA
    Posts
    13

    Default Re: New GA-Z170x Gaming 3 - came with wrong BIOS installed - could be causing issues with GPU?

    Well, using logic I figured that a rev 1.1 BIOS version on a rev 1.0 board wasn't right, so downloaded the latest official version F6 from the gigabyte site and used Q-flash procedure to flash.
    Went without a hitch, but sadly didn't fix the issue with my graphics card. I'll just keep using it until my replacement arrives on Wednesday - I game with headphones so I won't be bothered by the noise of the GPU fans going full speed. And it will certainly keep the GPU nice and cool!

    Are there any firmware versions (beta perhaps?) beyond F6 for this board?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •