Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: Need help with device detection GA-Z87-D3HP




  1. #1
    EdgeClub is offline Junior Member
    Join Date
    Feb 2017
    Location
    Texas
    Posts
    2

    Default Need help with device detection GA-Z87-D3HP

    Guys, is this a BIOS problem or more a Windows problem. The detection data is not based "initially" on my drivers because this is prior to me installing them. It is what is detected from Windows Setup initially, so it's not drivers from me. It comes down to what Windows detects during setup. Either it's incorrect BIOS data or Windows detection of the BIOS data.... in ACPI I presume? I'm using the F7 BIOS from Gigabyte for GA-Z87-D3HP.


    I'm going to paste information from my Gigabyte Support Ticket here:
    On a previous ticket, I was going back from UEFI to BIOS. I could not POST any more. I resolved this issue. I tried many times to install Win 7 and Win 10 without success. The machine took 3 days to do the initial Windows Updates. Also, it did not detect my sound card or drivers for EHCI usb either. I researched the internet and found no solution. I tried many things to resolve this, and finally I decided that UEFI must set some data in the BIOS on the motherboard because even CMOS reset, battery removed, many times did not clear it fully. I always had my options already set AND it always had the "Boot Windows Boot Manager" option, but it said it was not available. Yes, I had the BIOS set for "legacy only". So, I reflashed my BIOS to F7, all is good. However, now Windows detects "Intel PCI Express Root Port 4 [C1]" now. I never had this device before.

    This is a conflict with my sound card in the PCI slot. These ports are shared.

    I've looked through the registry and found all the connections to this device and then compared my other registry backups to see what's different. This device has the EXACT same siblings and ID's as it should, only the Root ID is the problem.

    I should have these:
    PCI\VEN_8086&DEV_244E&SUBSYS_50011458&REV_D4\3&115 83659&0&E3
    PCI\VEN_8086&DEV_244E&SUBSYS_88921458&REV_41\4&131 5813&1&00E3

    Translation:
    Intel(R) 82801 PCI Bridge - 244E
    Intel(R) 82801 PCI Bridge - 2448


    [Current device ID]
    PCI\VEN_8086&DEV_244E&SUBSYS_88921458&REV_41\4&131 5813&1&00E3
    PCI\VEN_8086&DEV_8C16&SUBSYS_50011458&REV_D4\3&115 83659&0&E3

    Translation:
    Intel(R) 82801 PCI Bridge - 244E
    Intel(R) 8 Series/C220 Series PCI Express Root Port #4 - 8C16


    Do you see the connections? Same on everything except DEV_8C16 instead of another DEV_244E.

    I can install and get into Windows fine, except if I enable my sound card. Then I crash when the PCI Bus enumerates.

    As I said, I've tried Win 7 and Win 10. It's not drivers, because I'm using the same ones I always have and they are precompiled.

    I did notice this though, is this correct?
    Intel IME v9.0, Build 1482, Hot Fix 30
    Intel IME Recovery Image v9.0, Build 1482, Hot Fix 30
    Intel IME FITC v9.0, Build 1467, Hot Fix 22

    [Gigabyte Support]
    What sound card and does installing the drivers remove the yellow mark?

    [My Latest Response]
    Sound Card = Creative SB Audigy 2 ZS
    PCI\VEN_1102&DEV_0004&SUBSYS_20021102&REV_04

    It has always been this:
    [Parent]
    PCI\VEN_8086&DEV_244E&SUBSYS_88921458&REV_41\4&21c 5b70c&0&00E3

    There isn't a yellow "bang" mark. Once the drivers are installed for that sound card, and you reboot OR if you have it disabled and enable it, CRASH! BSOD Crash.

    Currently I have physically removed the Creative SB sound card, and I'm using onboard sound.

    The problem is the detection of the #4 PCIe slot, which never was there before. There is something UEFI has changed in my BIOS that even flashing the BIOS has not corrected. And yes, I did do Optimized Defaults after flashing the BIOS. I'm sure it's the same physical device detected on the motherboard, but it's the way Windows interprets the function of the device that is causing the problem.

    In other words, the dmi_pci.inf detection should be used instead of lynxpointsystem.inf which now is favored. But Windows does not see the device in dm_pci.inf any longer because that's not what is being detected. So I can't force the driver.
    Last edited by EdgeClub; 02-15-2017 at 08:14 AM. Reason: Adding BIOS version

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •