Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: GA-Z77X-UP5 TH corrupt bios or other issues ?




  1. #1
    N00bfr0mh3LL is offline Junior Member
    Join Date
    May 2017
    Location
    India
    Posts
    1

    Default GA-Z77X-UP5 TH corrupt bios or other issues ?

    I have a Gigabyte motherboard GA-Z77X-UP5-TH
    GA-Z77X-UP5 TH (rev. 1.0) | Motherboard - GIGABYTE

    For past 2 weeks it is having lot of issues (I have to keep the machine on) as If i try to restart the same or power off. it gives lot of trouble starting up properly.

    I get a Main Bios Corrupt Screen. Machine wont bootup (I have unplug ram, unplug graphics card, remove cmos battery etc. etc.)
    I have to try various things to get it started.
    Sometimes it starts properly, sometimes takes time.. Not sure what is wrong and where..

    Can someone please help me how to proceed and fix this issue ?

    1. I have never touched this motherboard, overclocked or reflashed the bios.
    2. Its very difficult to enter the bios at the moment, I have to unplug, ram, GPU, remove CMOS battery, try to boot pressing case panel buttons here and there and then it boots.
    sometimes quick and sometimes takes lot of time.
    3. I dont know what is wrong and where.
    4. When it boots and enters bios, when I try to save changes and quit bios, it will not boot again..


    Please guide right way to fix the issue
    How to update properly, this is the only work PC I have in hand at the moment, and lot of important data on same.

  2. #2
    Join Date
    Mar 2017
    Location
    usa
    Posts
    4

    Default Re: GA-Z77X-UP5 TH corrupt bios or other issues ?

    I would look at your Power Supply first off. I had my old i5 2500k build do something similar to what you are saying besides the corrupt bios message but power supplies are sneaky like that sometimes. If you got a extra PSU to swap out, that would be my first bet. Mine would randomly cut out when watching Youtube or regular use.

    My next step if that don't work would be to look at your Ram and make sure it's working. if you have two sticks of memory try running with one and if it still messes up, replace it with your other stick. But when you're in a spot like you are, it is good to have a spare PC to test and swap things around. I refuse to have just one PC anymore. I learned my mistakes in the past. It sucks i know.
    Last edited by forlani101; 05-28-2017 at 03:05 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •