Absoultly gutted, about updating BIOS to latest version F22 for my Gigabyte GA-X99-SOC Force.

No POST after update to latest BIOS, before then board was running fine for the last 2 years, with only one BIOS update (which appears to have been removed F22h) since new.

Nothing has changed about the system, same RAM and everything. Wish I never updated it now. Only did this to get the new UEFI setup, the old one is slow and clunky.

Tried everything. Changing memory slots. Backup BIOS. CMOS reset. PSU switch trick. USB restore. Nothing works, damm thing is stuck on POST code 55, the board is like a brick.

I can see the when starting the code is 55, this does not change. The main BIOS is light is on, the computer shuts down, and changes to the backup BIOS with code 55 also, and just its there.

I read code 55 is a memory problem. Did Gigabyte code out my memory type? I tried generic stick from another computer, it did nothing to help.

Not like this is a new build. Has this stupid BIOS update killed my high-end board that is perfectly ok otherwise? How do I get it to start?