I've just built a new system: AMD Ryzen 7 1800x + Gigabyte AX370 Gaming 5 + 2x G.Skill FlareX 8GB RAM + Gigabyte GTX 1050 ti GI Gaming 4GB card + Windows 10 Pro x64.
System is working well with only the graphics card installed, but if I try to install any other expansion cards they don't work or prevent the system from booting.

Here's what I've tried so far:

1. 3Ware/LSI 9650SE 4LPML 4x SATA RAID adapter. Tried in both the PCIe 8x slot and the PCIe 4x slot. Can boot in to Windows but cannot load the drivers. Windows hangs when the drivers are loading and eventually gives a DPC Watchdog Violation.

2. ASMedia 1061 2x SATA 3 card (PCIe 1x). Depending which slot it is installed in, either the system boot loops at post or it posts ok but cannot load Windows anymore. Removing the card allow Windows to load again.

3. PCIe 1x USB 3.0 card (NEC chip). Same as 2. Either can't post or can post but not load Windows.

All of these are standard pc expansion cards which have been used in multiple intel-based pc's in the past on Windows 7 and Windows 10. They have always work flawlessly. Why do they not work on a Ryzen pc? Can an updated bios fix these issues? If I can't use any of my expansion cards I will have to return the entire system for a refund. An AMD Ryzen pc that is not actually pc compatible is useless to me.