Greetings,

My GA-X99-UD5 rev 1.0 motherboard has operated flawlessly for a couple of years. Today I encountered a really strange issue. I powered on my computer as usual and it would not power up. Used the power ON button in the motherboard and it powered on but no Debug LED numbers where displayed. I could see all the lights in my computer case on but hardrives would not power up either, no keyboard signal nor anything in the screen.

Power off using the power ON button would not work so I had to cut power, wait a few seconds and power ON again every time. I tried Clear CMOS button to no effect. I checked all PSU voltages with my FrozenCPU PSU tool, all checked fine. Tried another power supply just in case with the same results.

I was about to give up and replace motherboard but it occured me to try the backup BIOS. Suddenly everything worked, the computer booted up directly into windows desktop (without entering the login screen). OC settings are the same as they have been for the past 2 years, RAID configuration appears to be untouched.

Now I'm backing up everything. Any clue about what's going on? Perhaps a standby mode that went wrong?

Thank you in advance for your replies.