Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Can't access BIOS after upgrading (X470 Aorus Ultra Gaming)

  1. #1
    fvaldivial is offline Junior Member
    Join Date
    Sep 2019

    Default Can't access BIOS after upgrading (X470 Aorus Ultra Gaming)

    I bought a X470 Aorus Ultra Gaming for use with a Ryzen 3600 processor. As it is not compatible out of the box, I put a 2600 and updated the BIOS via Q-Flash, started in F6, F30, F31, F40 (this one is the first one compatible with 3rd gen Ryzen). When I got to F40, Q-Flash exited and the computer booted directly to Windows, and I couldn't access the bios. I flashed the backup bios pressing reset and power buttons for 10 seconds and tried again, but got the same result, after flashing F40 bios is no longer accessible. Now the Ryzen 5 3600 processor works and I can boot to Windows, but I can't enter the bios and couln't flash the backup bios, and won't be trying again as I don't have the 2600 processor at hand. What should I do? Maybe flash F41 with efiflash?
    Thanks in advance

  2. #2
    Chike is offline Senior Member
    Join Date
    Jun 2009

    Default Re: Can't access BIOS after upgrading (X470 Aorus Ultra Gaming)

    How to access BIOS in Windows 10 - Tech Advisor
    scroll down to Accessing the BIOS on newer machines

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts