Does anyone have any idea what might be wrong with my Gigabyte RTX 2070 Super Gaming OC card?

Everything was humming along nicely until about 2 days ago (card is about 3 months old). I noticed some major performance dips in benchmarks I ran (FFXV bench, 3Dmark) - like over 1000 points difference. I loaded up AORUS Engine and noticed that it no longer will allow me to adjust any voltage settings or temp/power limits. For instance the, the GPU Voltage (%) is 0, and cannot be adjusted. Clicking on the lock icon to unlock voltage adjustments does nothing. The same for Power Target (%), which was initially 105 but now shows 0. Again, the slider cannot be adjusted even though it isn't greyed out -- clicking on the + does nothing. The only one I can adjust is the Target Temp, but when I "Apply" the new target, AORUS freezes my system completely. The only overclocking I had done was using the AORUS Engine automatic scan feature, which sets all the appropriate voltages automatically. If I try and run the scan now, it will freeze my system, and eventually the scan fails. I downloaded MSI Afterburner, since I thought maybe it was just Gigabyte's bad software, but I had the same result. Voltages and target %s cannot be changed, and the auto scan instantly fails.

Using GPU-Z, it seems my core speed is locked at 1605MHz and my PerfCap is permanently showing "Idle." I am not getting any boost clocks in any bench, including the built in render test in GPU-Z, Unigine Heaven, Furmark, etc. No matter what I run, GPU-Z shows that max clock at 1605MHz and the "PerfCap" is idle. I am not using any power saving features in Windows or the NVIDIA drivers (everything is set to Max Performance).

I am at a loss here. Could it be a corrupted GPU BIOS? Power supply Issue? I tried reseating the card, swapping the power cables, and even did a complete Windows clean install and nothing has helped.