Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: Unknown device - USB Card reader won't install




  1. #1
    Join Date
    Apr 2005
    Location
    Ontario, Canada
    Posts
    1,364

    Default Unknown device - USB Card reader won't install

    Ok, I am sick of this damn USB 2.0 internal card reader. It just will not install properly. When I first put it in, it recognized and installed. THen after a few reboots, it disappeared off of "My Computer" aand appeared as an unknown device in "hardware manager". I have spent the better part of a week googling the subject looking for answers. The few suggestions I found were basically worthless. I tried starting in safe mode to clean out the USB stuff with the "show hidden devices" tab. That produced no results. In fact, it didn't even show any extra hidden devices. Anyone else get tortured by one of these things? I am ready to throw it out the window. And before I am asked, there are no drivers to load for it, WIN XP is supposed to do all that. And I even tried loading WIN 2000 drivers for it and it won't even start the install because it cannot be found. It is a Vantec USB 2.0 Internal Card reader. Anyone?!?!?!?
    GIgabyte GA-990FXA-UD3
    AMD FX8120 @ 4GHz
    Patriot 1866MHz EL series 2X4GB DDR3
    Powercolour HD 6970 2GB w/XFX 8800GT 512MB Hybrid PhysX
    Creative X-FI titanium HD w/Technics class A 300W amp and tower speakers
    PC P&C 500W PSU
    2TB Seagate
    Coolermaster 690II w/Corsair H100 tucked under the hood

  2. #2
    Join Date
    Apr 2005
    Location
    Ontario, Canada
    Posts
    1,364

    Default Re: Unknown device - USB Card reader won't install

    - bump -

    Anyone?
    GIgabyte GA-990FXA-UD3
    AMD FX8120 @ 4GHz
    Patriot 1866MHz EL series 2X4GB DDR3
    Powercolour HD 6970 2GB w/XFX 8800GT 512MB Hybrid PhysX
    Creative X-FI titanium HD w/Technics class A 300W amp and tower speakers
    PC P&C 500W PSU
    2TB Seagate
    Coolermaster 690II w/Corsair H100 tucked under the hood

  3. #3
    Join Date
    Oct 2004
    Location
    British Columbia, Canada
    Posts
    870

    Default Re: Unknown device - USB Card reader won't install

    My friend just bought a 1GB USB flash drive. Had no USB ports on the back of his computer left, so he plugged the ones on the front of case into the motherboard and then pluged in his usb device... XP found it as an unknown device. He then pulled it out of the USB port and it was HOT. He later found out he had pluged the USB cords in the wrong way and fried his flash drive.

    Check to make sure it's plugged in the right way. You may have killed it.
    My Current Rigs:
    Antec P180, OCZ Powerstream 520W, DFI nF4 SLI-DR Expert, AMD X2 4400 w/XP120(2.6GHz@1.45v), 2x1GB OCZ Platnium PC3200, BFG 7900GT@592/800(1.6), WD 250GB SATA, Maxtor 120GB IDE, LG DVD/CD Combo(black), Sony DRU-810 DL DVD Burner(black)
    3DMark01:25379, 3DMark03:19746
    3DMark05:9294, 3DMark06:5340

    Raidmax Cobra, Fortron PN-400W, ASUS A8N-E(nF4 Ultra), X2 3800 w/AMD heatpipe cooler, 2x 512MB Crucial Balistix, ATI X300, WD 250GB IDE, Samsung 16x DVD/RW

  4. #4
    Join Date
    Apr 2005
    Location
    Ontario, Canada
    Posts
    1,364

    Default Re: Unknown device - USB Card reader won't install

    I am 100% sure it was plugged in properly. It did actully install correctly when I first installed it and 4 removeable drives showed up in My Computer. I even transferred files from a SD, MMC and a Compact Flash card for 2 days before it stopped cooperating. I have had this issue before with other PCs and these damn flash drives. I have only built 1 PC that liked the flashdrive and it was a MATX MSI board. I have also read up on the subject on google and found many people with the same problem, just noone has a solution. Windows XP sucks and is a pain in the ass when it comes to USB problems. Oh well.
    GIgabyte GA-990FXA-UD3
    AMD FX8120 @ 4GHz
    Patriot 1866MHz EL series 2X4GB DDR3
    Powercolour HD 6970 2GB w/XFX 8800GT 512MB Hybrid PhysX
    Creative X-FI titanium HD w/Technics class A 300W amp and tower speakers
    PC P&C 500W PSU
    2TB Seagate
    Coolermaster 690II w/Corsair H100 tucked under the hood

  5. Default Re: Unknown device - USB Card reader won't install

    Yup, I had the same happen with a different brand usb memory card reader. It showed 4 removable drives, but none of them worked. After working with it for about half an hour, I gave up and used a different computer. It worked fine on that one. I later turned off the computer and then plugged it in on the funky computer that put up the 4 removable drives. It worked for once. I'm not sure if it will work on yours, but atleast it's a stab at the problem. The problem is deffinately with the operating system, not the usb reader. Hope this helps.

  6. #6
    Join Date
    Apr 2005
    Location
    Ontario, Canada
    Posts
    1,364

    Default Re: Unknown device - USB Card reader won't install

    I love how it states that no drivers are needed for Win XP, just plug and play. What a crock. I am looking into Windows alternatives as we speak. I am more that sick of the issues with Microsoft's garbage. I have had the same success as you, what works on one PC may not work on another.
    GIgabyte GA-990FXA-UD3
    AMD FX8120 @ 4GHz
    Patriot 1866MHz EL series 2X4GB DDR3
    Powercolour HD 6970 2GB w/XFX 8800GT 512MB Hybrid PhysX
    Creative X-FI titanium HD w/Technics class A 300W amp and tower speakers
    PC P&C 500W PSU
    2TB Seagate
    Coolermaster 690II w/Corsair H100 tucked under the hood

  7. #7
    Join Date
    Nov 2003
    Location
    Minnesota, United States
    Posts
    4,543

    Default Re: Unknown device - USB Card reader won't install

    Have you tried Windows Update? It's possible, abiet unlikely, that XP does indeed have it available as a driver download.

  8. #8
    Join Date
    Feb 2006
    Posts
    2

    Default Re: Unknown device - USB Card reader won't install

    Hi all, I was looking for a solution to this problem about a month ago and stumbled upon this forum just to find out there were a few more like me out there, but I have the solution now so I came back to share it with you all, I have WinXP running on my PC and all I did was update to Service Pack 2 and the problem is gone, I can use my card reader anytime I want now, it's a Vantec all in one reader, or the temporary solution for me was to go to Control Panel, System and Device Manager and erase the reader from there (wich has an exclamatino point on it) and reboot, it should recognize it again for about 1 or 2 more reboots, well my job is done hope this helps you all.

  9. #9
    Join Date
    Apr 2005
    Location
    Ontario, Canada
    Posts
    1,364

    Default Re: Unknown device - USB Card reader won't install

    I already was onservice pack 2. My issue was never resolved and I just uninstalled it. I tried everything you mentioned and even tried some much more extreme methods.
    GIgabyte GA-990FXA-UD3
    AMD FX8120 @ 4GHz
    Patriot 1866MHz EL series 2X4GB DDR3
    Powercolour HD 6970 2GB w/XFX 8800GT 512MB Hybrid PhysX
    Creative X-FI titanium HD w/Technics class A 300W amp and tower speakers
    PC P&C 500W PSU
    2TB Seagate
    Coolermaster 690II w/Corsair H100 tucked under the hood

  10. #10
    Join Date
    Dec 2002
    Location
    Winnipeg, Canada
    Posts
    848

    Default Re: Unknown device - USB Card reader won't install

    Those things are actually meant to be plugged into a usb port when the computer is on. But many makers use the same device and put connections on to plug onto the pins of the mobo instead of the intended usb plug. This make it hard to connect all of the pins at the same time like they are suposed to be.(that is if they are individual and not on a 9 pin block)(I soldered a 9 pin block onto one and that made it stay connected)

    And yes these things are torture sometimes.
    Last edited by maximus7001; 02-24-2006 at 01:50 PM.
    athlon xp-m@2456mhz(12x204)
    tt aquariusII liquid cooled/ arctic silver ceramique
    asus a7n8xe-dlx
    thermaltake xaserIII lanfire
    bfg 6800gt
    seagate sataII 250gb/seagate 7200rpm 160gb ide
    samsung dvdrw
    2x1024 kingston hyper-x pc3200/ windows xp pro sp3
    logitech mx518/ logitech wingman rumble
    2x samsung 955df 19"/ canon i960
    creative x-fi fatal1ty 64mb/ altec lansing 251-5.1
    mushkin 550w

    opteron 146 @ 2850 (10x285)
    DFI infinity nf4 ultra
    thermaltake tsunami dream -black
    seagate sataII 500gb
    evga 8600gt oc ssc edition
    samsung sata dvd-rw
    2x1024 ocz black
    logitech ifeel/ nec accusync 75f
    ocz fatal1ty 550w

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •