Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: drivers not installed code 28




  1. #1
    Join Date
    Feb 2006
    Posts
    54

    Default drivers not installed code 28

    Windows will not install drivers for my Logitech USB Premium 350 head set.

    Windows keeps asking me to look for the drivers when they should install automatically. When I look in the Device manager, it says "drivers not installed code 28."

    Microsoft only suggests reinstalling the drivers which I have done. I have checks my system for errors and gotten rid of files I dont need from the registry. I have updated all other drivers. I am running Windows XP Pro with Sp2.

    Asrock 939SLI32-eSATA2
    2 gigs GSkill ram
    Geforce 6800 GS
    Maxtor 160 gig HD
    SB Live
    AMD Athalon 64 3700 san diego

    I spoke with the Logitech cust service guy who was very helpful, but didn't find the problem. Has anyone else had this?

  2. #2
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default Re: drivers not installed code 28

    What does your headset do that requires drivers? It is a set of small speakers, just like any other speakers that you hook up to your system. I've been running a set of Altec Lansing for well over a year now and have never had issues, even with the microphone.

    If the headsets are not putting out any sounds, double check the settings of the sound device.
    Old age and treachery will overcome youth and skill
    My Toys

  3. #3
    Join Date
    Feb 2006
    Posts
    54

    Default Re: drivers not installed code 28

    It is a usb headset. It has digital sound, thats why. I am having problems with my usb devices.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •